Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11195 closed enhancement (duplicate)

LU decomposition for exact matrices

Reported by: rbeezer Owned by: jason, was
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords:
Cc: Merged in:
Authors: Reviewers: Rob Beezer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This was meant for instructional purposes, but for some exact fields (eg finite fields) it is twice as fast as echelon form when Cythonized, as theory would predict.

So it could be the basis of a fast alternative algorithm for solve_right and friends.

Attachments (1)

trac_11195-LU-decomposition-exact.patch (3.1 KB) - added by rbeezer 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by rbeezer

comment:1 Changed 10 years ago by rbeezer

  • Authors set to Rob Beezer

Patch is here for safe-keeping, but not ready for review. It should run just fine, needs caching perhaps, and needs docstring and doctests.

comment:2 Changed 10 years ago by jdemeyer

  • Authors Rob Beezer deleted
  • Resolution set to duplicate
  • Reviewers set to Rob Beezer
  • Status changed from new to closed

Duplicate of #11259.

comment:3 Changed 10 years ago by mvngu

  • Milestone changed from sage-4.7.1 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.