Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1118 closed enhancement (duplicate)

cputime should include the cpu times of all subprocesses

Reported by: malb Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Paul Zimmermann wrote: """ It seems the cpu time reported by SAGE does not include that of the spawned processes

mermoz% sage
----------------------------------------------------------------------
| SAGE Version 2.8.10, Release Date: 2007-10-28                      |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------

sage: p=65257526772644948764799212887702573391887715235981530343703506731
sage: time FindGroupOrder(p,489731259)
CPU times: user 0.87 s, sys: 0.07 s, total: 0.94 s
Wall time: 70.30
2^2 * 3^2 * 7 * 13 * 5521 * 589213 * 1103171 * 1149307 * 1310261 * 10091759 * 63065897 * 120597437 * 48024231181

I doubt the given cpu times take into account the PARI/GP computations. As a comparison, Magma takes 55s for that computation on my computer.

The wall time is not very useful (my machine has a load of 3-4). It would be more useful to have to cpu time used by the spawned processes, or simply the total cpu time used by SAGE and those processes. """

Thus we should figure out how to do this in a portable way. May the POSIX gurus speak up!

Change History (4)

comment:1 Changed 13 years ago by malb

I forgot to include the actual code that was run.

def FindGroupOrder(p,s):
   K = GF(p)
   v = K(4*s)
   u = K(s^2-5)
   x = u^3
   b = 4*x*v
   a = (v-u)^3*(3*u+v)
   A = a/b-2
   x = x/v^3
   b = x^3 + A*x^2 + x
   E = EllipticCurve(K,[0,b*A,0,b^2,0])
   return factor(E.cardinality())

comment:2 Changed 12 years ago by was

  • Milestone changed from sage-3.2.1 to sage-wishlist

comment:3 Changed 12 years ago by malb

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #4761 and thus I am closing this ticket.

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.