Opened 14 years ago

Closed 13 years ago

#1116 closed defect (fixed)

[fixed] sage -sdist recreates certain empty files in local/bin

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-2.10.2
Component: distribution Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

mabshoff@sage:/tmp/Work-mabshoff/sage-2.8.12.alpha1/local/bin$ hg status
? sage-cleaner.orig
? sage-clone.orig
? sage-lo
? sage-make

Change History (4)

comment:1 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.10 to sage-2.9

This annoys me and causes the $SAGE_LOCAL/bin/ repo to report files with unclear status.

Cheers,

Michael

comment:2 Changed 13 years ago by mabshoff

  • Status changed from new to assigned
  • Summary changed from sage -sdist recreates certain empty files in local/bin to [fixed, needs to be verified] sage -sdist recreates certain empty files in local/bin

I removed the offending files from the sage_scripts repo. Once 2.10.2.alpha1 is out we ought to verify that the problem is really gone.

Cheers,

Michael

comment:3 Changed 13 years ago by mabshoff

  • Summary changed from [fixed, needs to be verified] sage -sdist recreates certain empty files in local/bin to [fixed] sage -sdist recreates certain empty files in local/bin

I did some testing and it seems to work. I will reopen in case it turns out to be an incomplete fix.

Cheers,

Michael

comment:4 Changed 13 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in Sage 2.10.2.alpha1

Note: See TracTickets for help on using tickets.