Opened 10 years ago

Closed 8 years ago

#11123 closed defect (duplicate)

Plot connects parts of function over non-domain area

Reported by: kcrisman Owned by: jason, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords: domain plot
Cc: jondo Merged in:
Authors: Reviewers: Karl-Dieter Crisman, Robert Pollak
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

From this ask.sagemath question:

----------------------------------------------------------------------
| Sage Version 4.6.2, Release Date: 2011-02-25                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
sage: plot(sqrt(sin(x)),(0,10))
verbose 0 (4069: plot.py, generate_plot_points) WARNING: When plotting, failed to evaluate function at 74 points.
verbose 0 (4069: plot.py, generate_plot_points) Last error message: ''

The picture is attached.

Ideally, we would want plot to just not connect those pieces. With just sqrt(x) over -1 to 1, it's not a problem, but this really does look bad.

Attachments (1)

tmp_0.png (17.5 KB) - added by kcrisman 10 years ago.
Shows the problem

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by kcrisman

Shows the problem

comment:1 Changed 8 years ago by jondo

  • Cc jondo added

This should be resolved as duplicate of #13246. This ticket is older, but the other one has discussion and a patch.

(It seems I cannot do this by myself.)

comment:2 Changed 8 years ago by kcrisman

  • Milestone set to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Agreed.

(It's true you can't do this by yourself, but you can change the status and then the release manager can close it.)

comment:3 Changed 8 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman
  • Status changed from needs_review to positive_review

And now just add your real name to the list of reviewers (I couldn't find it easily on Trac).

comment:4 Changed 8 years ago by jondo

  • Reviewers changed from Karl-Dieter Crisman to Karl-Dieter Crisman, Robert Pollak

Thank you.

(Ah, as a newbie I had not noticed that this special milestone is used instead of having 'resolved' and 'closed' as separate steps.)

comment:5 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.