Opened 8 years ago

Closed 6 years ago

#11122 closed enhancement (duplicate)

Implementation of the Demazure product in Coxeter groups

Reported by: stumpc5 Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords: Demazure product, subword complex
Cc: Merged in:
Authors: Reviewers: Christian Stump
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

The provided patch implements the Demazure product of a word in the generators of a Coxeter group.

The definition can be found e.g. in "Knutson, Miller - Subword complexes for Coxeter groups".

            sage: W = CoxeterGroup(['A',2],index_set=[1,2])

            sage: w = W.demazure_product([2,2,1])
            sage: w.reduced_word()
            word: 21

            sage: w = W.demazure_product([2,1,2,1,2])
            sage: w.reduced_word()
            word: 121

            sage: W = CoxeterGroup(['B',2],index_set=[1,2])

            sage: w = W.demazure_product([2,1,2,1,2])
            sage: w.reduced_word()
            word: 2121

As I also needed it, the patch provides in addition a method returning the cartan type of a Coxeter group.

Duplicate of #12774.

Attachments (1)

trac_11122-demazure_product-cs.patch (2.2 KB) - added by stumpc5 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by stumpc5

  • Component changed from PLEASE CHANGE to combinatorics
  • Description modified (diff)
  • Status changed from new to needs_work

Changed 8 years ago by stumpc5

comment:2 Changed 8 years ago by stumpc5

  • Dependencies set to 11187
  • Description modified (diff)
  • Milestone set to sage-4.7.1
  • Owner changed from tbd to (none)

comment:3 Changed 8 years ago by chapoton

  • Dependencies changed from 11187 to #11187

comment:4 Changed 8 years ago by chapoton

  • Dependencies changed from #11187 to #11187, #8359

comment:5 Changed 8 years ago by stumpc5

  • Milestone changed from sage-4.7.1 to sage-4.7.2

comment:6 Changed 7 years ago by mshimo

This has been folded into 12774.

comment:7 Changed 7 years ago by mshimo

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Reviewers set to mshimo
  • Status changed from needs_work to needs_review

comment:8 Changed 7 years ago by stumpc5

  • Status changed from needs_review to positive_review

comment:9 Changed 6 years ago by tscrim

  • Dependencies #11187, #8359 deleted

Removed dependencies so this looks like a duplicate ticket.

comment:10 Changed 6 years ago by jdemeyer

  • Authors Christian Stump deleted
  • Description modified (diff)
  • Resolution set to duplicate
  • Reviewers changed from mshimo to Christian Stump
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.