Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11094 closed enhancement (duplicate)

Isogenies of elliptic curves over finite fields

Reported by: defeo Owned by: cremona
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: elliptic curves Keywords: isogenies, finite fields
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Add algorithms to compute isogenies between elliptic curves over finite fields in any characteristic.

References:

[Cou94] Jean-Marc Couveignes, Quelques calculs en théorie des nombres, Ph.D. thesis, Université de Bordeaux, 1994.

[Cou96] Jean-Marc Couveignes, Computing l-Isogenies using the p-Torsion, ANTS-II: Proceedings of the Second International Symposium on Algorithmic Number Theory (London, UK), Springer-Verlag, 1996, pp. 59–65.

[LS08] Reynald Lercier and Thomas Sirvent, On Elkies subgroups of ell-torsion points in elliptic curves defined over a finite field, Journal de théorie des nombres de Bordeaux 20 (2008), no. 3, 783–797.

Change History (2)

comment:1 Changed 10 years ago by defeo

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 10 years ago by mvngu

  • Authors Luca De Feo deleted
  • Milestone changed from sage-feature to sage-duplicate/invalid/wontfix

Close as duplicate of #11093.

Note: See TracTickets for help on using tickets.