Opened 10 years ago

Closed 7 years ago

#11067 closed enhancement (duplicate)

make it possible to use lstlisting instead of verbose in latex document without breaking "sage -t"

Reported by: was Owned by: mvngu
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: doctest framework Keywords: doctest, latex
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Right now example code has to be in \begin{verbatim}/\end{verbatim} blocks. However, lstlisting looks much better. With this patch one can write latex documents and have "sage -t" work on them, if they use one or the other type of blocks.

It's probably not optimal -- it would be better to maybe make this customizable or something. I don't know.

Attachments (1)

trac_11067.patch (1.9 KB) - added by was 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by was

comment:1 Changed 10 years ago by was

  • Status changed from new to needs_review

comment:2 Changed 10 years ago by novoselt

This ticket may be related to #10146 (SageTeX with support for lstlistings).

comment:3 Changed 9 years ago by jdemeyer

Please fill in your real name as Author.

comment:4 Changed 8 years ago by roed

  • Component changed from doctest to doctest framework

comment:5 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:6 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:7 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:8 Changed 7 years ago by chapoton

  • Keywords doctest latex added
  • Milestone changed from sage-6.3 to sage-duplicate/invalid/wontfix

I propose to close this as a duplicate of #3912 (which needs review)

comment:9 Changed 7 years ago by aapitzsch

  • Status changed from needs_review to positive_review

comment:10 Changed 7 years ago by chapoton

Thanks a lot ! Would you maybe have time to have a look at #3912 ?

comment:11 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.