Opened 7 years ago

Closed 5 years ago

#11034 closed defect (duplicate)

bug in the way vectors are created for submodules of free modules

Reported by: was Owned by: jason, was
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords:
Cc: minz Merged in:
Authors: Reviewers: William Stein, Moritz Minzlaff
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

Let R be a ring with fraction field K.

When you create a R-submodule of K^n (with K!=QQ) the vectors 
are created in the ring R not the fraction field.  This breaks things 
when the submodule is not in R^n.

Fixed by #11751.

Change History (10)

comment:1 Changed 7 years ago by was

  • Description modified (diff)

comment:2 Changed 7 years ago by was

  • Description modified (diff)

comment:3 Changed 6 years ago by minz

  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to defect

The new version adds a doctest (and is slightly modified to make the doctest work).

The only doctest failure I received was related to the startup time as checked by startup.py. Curiously enough, replicating the same test on my local machine returned True. (Replicating as in: not running the doctest itself as it always returns True when not on sage.math.)

comment:4 Changed 6 years ago by minz

Apply trac_11034.v2.patch

comment:5 Changed 6 years ago by minz

  • Authors set to William Stein, Moritz Minzlaff
  • Description modified (diff)

comment:6 Changed 6 years ago by mderickx

  • Status changed from needs_review to needs_work
  • Work issues set to rebase

This patch fails to apply to 4.7.2.alpha2

md:sage maarten$ mhg qim -P http://trac.sagemath.org/sage_trac/raw-attachment/ticket/11034/trac_11034.v2.patch
adding trac_11034.v2.patch to series file
applying trac_11034.v2.patch
patching file sage/modules/free_module.py
Hunk #1 FAILED at 4902
1 out of 1 hunks FAILED -- saving rejects to file sage/modules/free_module.py.rej
patching file sage/modules/free_module_element.pyx
Hunk #3 succeeded at 3356 with fuzz 1 (offset 701 lines).
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir
errors during apply, please fix and refresh trac_11034.v2.patch

But there was some stupid duplicate of work so there is another ticket wich fixes the same problem at http://trac.sagemath.org/sage_trac/ticket/11751 so if that one gets positive review and merged we can close this one.

comment:7 Changed 5 years ago by minz

Since #11751 received a positive review and was merged in 4.7.2, maybe this ticket can be closed? (I also checked the test in the docstring of this patch and it passes in Sage 5.0.)

comment:8 Changed 5 years ago by was

  • Description modified (diff)
  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to positive_review

I can confirm that your examples work fine in sage-5.0. So this can be closed. The proper way to do that is "positive review".

comment:9 Changed 5 years ago by was

  • Reviewers set to William Stein

comment:10 Changed 5 years ago by jdemeyer

  • Authors William Stein, Moritz Minzlaff deleted
  • Description modified (diff)
  • Resolution set to duplicate
  • Reviewers changed from William Stein to William Stein, Moritz Minzlaff
  • Status changed from positive_review to closed
  • Work issues rebase deleted
Note: See TracTickets for help on using tickets.