Opened 11 years ago

Closed 11 years ago

#10972 closed defect (duplicate)

Make sure symbolic functions return symbolic answers

Reported by: kcrisman Owned by: burcin
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: jdemeyer Merged in:
Authors: Reviewers: Burcin Erocal
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

From sage-support:

> I'm running Sage 4.6.2.  I've just noticed that if I evaluate various 
> symbolic expressions which return 0 then the 0 returned is a python int, 
> rather than a Sage integer.  examples of such expressions are sin(0), 
> tan(0), ln(0). 
> Is there a reason for this or is it a bug? 


I would consider this a bug, but because it should return a symbolic 
expression. 
sage: a = sin(pi) 
sage: a 
0 
sage: type(a) 
<type 'sage.symbolic.expression.Expression'> 
It's possible to get this behavior: 
sage: type(sin(0,hold=True).simplify()) 
<type 'sage.symbolic.expression.Expression'> 
Anyway, this is an oversight, I would say.  Anyone else care to 
comment?  Otherwise it would be great if you'd file a bug report. 
This is important to fix, because some Sage code depends on the input 
in integer form being Sage integer or something else with Sage 
methods, not a Python int, and one could imagine someone relying on 
this and getting a nasty exception. 

Change History (4)

comment:1 Changed 11 years ago by burcin

  • Cc jdemeyer added
  • Milestone set to sage-duplicate/invalid/wontfix

This is a duplicate of #10133.

comment:2 Changed 11 years ago by jdemeyer

  • Reviewers set to Burcin Erocal
  • Status changed from new to needs_review

comment:3 Changed 11 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:4 Changed 11 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.