Opened 13 years ago

Closed 13 years ago

#1094 closed defect (duplicate)

small memleaks exposed by ntl_ZZ_pEX (from 2.8.12.alpha0)

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: memleak Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

ntl_ZZ_pEX.py

==4652== 408 (24 direct, 384 indirect) bytes in 3 blocks are definitely lost in loss record 635 of 1,862
==4652==    at 0x4A1C344: operator new(unsigned long) (vg_replace_malloc.c:227)
==4652==    by 0x6041AB6: ZZ_pE_to_ZZ_pX (in /tmp/Work-mabshoff/sage-2.8.11/devel/sage-main/c_lib/libcsage.so)
==4652==    by 0xCE6A067: __pyx_f_4sage_4libs_3ntl_9ntl_ZZ_pE_9ntl_ZZ_pE_get_as_ZZ_pX (ntl_ZZ_pE.cpp:2514)
==4652==    by 0xCE6889E: __pyx_pf_4sage_4libs_3ntl_9ntl_ZZ_pE_9ntl_ZZ_pE___reduce__(_object*, _object*) (ntl_ZZ_pE.cpp:1661
)
==4652==    by 0x415522: PyObject_Call (abstract.c:1860)
==4652==    by 0x47C850: PyEval_CallObjectWithKeywords (ceval.c:3433)
==4652==    by 0x4589BF: object_reduce_ex (typeobject.c:2786)
==4652==    by 0x415522: PyObject_Call (abstract.c:1860)
==4652==    by 0x76F0743: save (cPickle.c:2495)
==4652==    by 0x76F1EEC: batch_list (cPickle.c:1558)
==4652==    by 0x76F0C7B: save (cPickle.c:1626)
==4652==    by 0x76F025F: save_tuple (cPickle.c:1381)

Cheers,

Michael

Change History (3)

comment:1 Changed 13 years ago by mabshoff

With Sage 2.10.alpha0 I get:

==26426== 408 (24 direct, 384 indirect) bytes in 3 blocks are definitely lost in loss record 5,211 of 7,513
==26426==    at 0x4A1C344: operator new(unsigned long) (vg_replace_malloc.c:227)
==26426==    by 0x6041A76: ZZ_pE_to_ZZ_pX (in /tmp/Work-mabshoff/release-cycle/sage-2.9.3.rc1ish/devel/sage-main/c_lib/libcs
age.so)
==26426==    by 0xD0170F7: __pyx_f_4sage_4libs_3ntl_9ntl_ZZ_pE_9ntl_ZZ_pE_get_as_ZZ_pX (ntl_ZZ_pE.cpp:4203)
==26426==    by 0xD01592E: __pyx_pf_4sage_4libs_3ntl_9ntl_ZZ_pE_9ntl_ZZ_pE___reduce__(_object*, _object*) (ntl_ZZ_pE.cpp:312
6)

Total losses:

==26426== LEAK SUMMARY:
==26426==    definitely lost: 24 bytes in 3 blocks.
==26426==    indirectly lost: 384 bytes in 6 blocks.
==26426==      possibly lost: 258,375 bytes in 780 blocks.
==26426==    still reachable: 29,398,267 bytes in 182,476 blocks.
==26426==         suppressed: 0 bytes in 0 blocks.

Cheers,

Michael

comment:2 Changed 13 years ago by mabshoff

This looks like a dupe of #1092.

Cheers,

Michael

comment:3 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.10 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.