Opened 10 years ago

Closed 10 years ago

#10937 closed defect (fixed)

bug in Dokchitser L.init_coeffs

Reported by: was Owned by: was
Priority: critical Milestone: sage-4.7
Component: number theory Keywords:
Cc: Merged in: sage-4.7.alpha4
Authors: William Stein, Jeroen Demeyer Reviewers: Robert Bradshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In the last month four people reported getting "RuntimeError?: Unable to create L-series, due to precision or other limits in PARI." when trying to input their own interesting L-series to the Dokchitser wrapper in Sage. The problem is in lfunctions/dokchitser.py; it's just a dumb little mistake. The attached patch fixes it. For review this will also need some doctests (the bug is here since the functionality was never tested!).

Attachments (2)

trac_10937.patch (2.7 KB) - added by was 10 years ago.
10937_doc.patch (1.2 KB) - added by jdemeyer 10 years ago.
Apply on top of previous

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by was

comment:1 Changed 10 years ago by was

  • Status changed from new to needs_review

comment:2 Changed 10 years ago by robertwb

  • Status changed from needs_review to positive_review

Ouch, I'd been bitten by that too. No idea the bug was so stupid, nice catch.

comment:3 Changed 10 years ago by jdemeyer

  • Authors set to William Stein
  • Reviewers set to Robert Bradshaw

comment:4 Changed 10 years ago by jdemeyer

  • Status changed from positive_review to needs_work

There is a warning building the documentation:

dochtml.log:/mnt/usb1/scratch/jdemeyer/merger/sage-4.7.alpha3/local/lib/python2.6/site-packages/sage/lfunctions/dokchitser.py:docstring of sage.lfunctions.dokchitser.Dokchitser.init_coeffs:51: (WARNING/2) Literal block expected; none found.

Changed 10 years ago by jdemeyer

Apply on top of previous

comment:5 Changed 10 years ago by jdemeyer

  • Authors changed from William Stein to William Stein, Jeroen Demeyer
  • Status changed from needs_work to needs_review

comment:6 Changed 10 years ago by was

  • Status changed from needs_review to positive_review

comment:7 Changed 10 years ago by jdemeyer

  • Merged in set to sage-4.7.alpha4
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.