Opened 10 years ago

Closed 5 years ago

#10922 closed defect (fixed)

Fix some multiline platonic solids plot documentation

Reported by: kcrisman Owned by: mvngu
Priority: minor Milestone: sage-6.9
Component: documentation Keywords:
Cc: robertwb, mvngu Merged in:
Authors: Frédéric Chapoton Reviewers: Nathann Cohen
Report Upstream: N/A Work issues:
Branch: c8ebabb (Commits) Commit: c8ebabb1c2e488455ac012550dc7231896799649
Dependencies: Stopgaps:

Description (last modified by kcrisman)

Some platonic solids in plot/plot3d/platonic.py do not evaluate correctly in the live documentation in the notebook, because they are spread over multiple lines. Things like

sage: dodecahedron(color='orange', opacity=0.8) + \
      sphere(size=0.5, color='black')

become split into the input cell and output cell.

I'm not sure if this is really a notebook bug or a parsing bug when the live documentation is made. An easy way to fix it is to change the line breaks but that would likely lead to less readability.

Attachments (1)

Screen Shot 2014-08-22 at 1.58.14 PM.png (18.0 KB) - added by kcrisman 6 years ago.
Picture of problem

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by aapitzsch

Could you improve the problem description. The problem is not clear to me.

comment:2 Changed 6 years ago by kcrisman

  • Description modified (diff)

It took me a while to reconstruct this! Thanks for the reminder.

Changed 6 years ago by kcrisman

Picture of problem

comment:3 Changed 5 years ago by chapoton

  • Authors set to Frédéric Chapoton
  • Branch set to u/chapoton/10922
  • Commit set to c8ebabb1c2e488455ac012550dc7231896799649
  • Status changed from new to needs_review

New commits:

c8ebabbtrac #10922 clean-up of doc of platonic solids

comment:4 Changed 5 years ago by ncohen

  • Reviewers set to Nathann Cohen
  • Status changed from needs_review to positive_review

Good to go!

About RR(1)->RR.one(). I assume that you do this because it is how it is 'advised' as it is apparently faster (I have no first-hand experience on these matters), but I still find RR(1) better for the doc since it is more user-friendly.

Well. Matters of taste.

Thanks for this branch,

Nathann

comment:5 Changed 5 years ago by chapoton

  • Milestone set to sage-6.9

comment:6 Changed 5 years ago by vbraun

  • Branch changed from u/chapoton/10922 to c8ebabb1c2e488455ac012550dc7231896799649
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.