Opened 10 years ago

Closed 10 years ago

#10904 closed defect (duplicate)

Certification of isomorphism of graphs

Reported by: aschilling Owned by: jason, ncohen, rlm
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graph theory Keywords: graphs
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The output of the crystal isomorphism is currently different whether or not one specifies edge_labels = True. For example without edge_labels = True the result is a bijection between the vertices of the graph:

    sage: D = digraphs.RandomDirectedGNP(6, .2)
    sage: D.is_isomorphic(D, certify = True)
    (True, {0: 0, 1: 1, 2: 2, 3: 3, 4: 4, 5: 5})

If in addition one specifies edge_labels=True this changes to some labeling of an extended digraph(?):

    sage: D.is_isomorphic(D,edge_labels=True, certify = True)
    {0: 0, 1: 1, 2: 2, 3: 3, 4: 4, 5: 5, 6: 6, 7: 7, 8: 8, 9: 9, 10: 10} 

Would it be possible to make the output with edge_labels = True consistent?

Change History (3)

comment:1 Changed 10 years ago by rlm

Fixed by #10549.

comment:2 Changed 10 years ago by rlm

  • Cc Robert Miller removed
  • Component changed from PLEASE CHANGE to graph theory
  • Milestone set to sage-4.7
  • Owner changed from tbd to jason, ncohen, rlm

PS - When CC'ing someone you need to use their track handle or an email address, otherwise they won't be notified.

comment:3 Changed 10 years ago by rlm

  • Milestone changed from sage-4.7 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Since there is no code here and the issue is fixed by #10549, which has been merged, I'm closing this ticket.

Note: See TracTickets for help on using tickets.