Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10789 closed defect (duplicate)

discriminant() returns pari library error on number field with non-integral coefficients

Reported by: katestange Owned by: davidloeffler
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: discriminant, number field
Cc: katestange Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by katestange)

Verified on nt.sagenb.org

Sage Version 4.6, Release Date: 2010-10-30

and on my computer,

Sage Version 4.6, Release Date: 2010-10-30.

At least the following should return "not implemented", but it gives an error in the pari library.

sage: L.<d> = NumberField(x^3 - 7/3*x^2 - 2/3*x + 1)

sage: L.discriminant()

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "_sage_input_4.py", line 10, in <module>
    exec compile(u'open("___code___.py","w").write("# -*- coding: utf-8 -*-\\n" + _support_.preparse_worksheet_cell(base64.b64decode("TC5kaXNjcmltaW5hbnQoKQ=="),globals())+"\\n"); execfile(os.path.abspath("___code___.py"))
  File "", line 1, in <module>
    
  File "/tmp/tmpSVah8D/___code___.py", line 2, in <module>
    exec compile(u'L.discriminant()
  File "", line 1, in <module>
    
  File "/home/sage/sage_install/sage-4.6/local/lib/python2.6/site-packages/sage/rings/number_field/number_field.py", line 3346, in discriminant
    self.__disc = ZZ(str(self.pari_polynomial().nfdisc()))
  File "gen.pyx", line 9897, in sage.libs.pari.gen._pari_trap (sage/libs/pari/gen.c:46278)
sage.libs.pari.gen.PariError:  (5)

Change History (3)

comment:1 Changed 10 years ago by katestange

  • Description modified (diff)
  • Summary changed from discriminant() returns error on number field with non-integral coefficients to discriminant() returns pari library error on number field with non-integral coefficients

comment:2 Changed 10 years ago by fwclarke

  • Resolution set to duplicate
  • Status changed from new to closed

This is essentially a duplicate of #252.

comment:3 Changed 10 years ago by mvngu

  • Milestone changed from sage-4.6.2 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.