Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10786 closed defect (duplicate)

misformatted cayley tables for matrix groups

Reported by: kcrisman Owned by: joyner
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: group theory Keywords:
Cc: rbeezer Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

G=SL(2,ZZ)
identity = matrix(ZZ, [[1,0], [0,1]])
G.cayley_table(names='elements',elements=[identity, -identity])

From this ask.sagemath.org question. Essentially, matrix groups don't seem to work out too well:

sage: G.cayley_table(names='elements',elements=[identity, -identity])
              *      [1 0]
[0 1] [-1  0]
[ 0 -1]
               +--------------------------------
    [1 0]
[0 1]|     [1 0]
[0 1] [-1  0]
[ 0 -1]
[-1  0]
[ 0 -1]| [-1  0]
[ 0 -1]     [1 0]
[0 1]

Change History (4)

comment:1 Changed 9 years ago by jhpalmieri

This is a duplicate of part of #10787. Can we close it?

comment:2 Changed 9 years ago by kcrisman

Yes, certainly.

comment:3 Changed 9 years ago by jhpalmieri

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 9 years ago by jhpalmieri

  • Milestone set to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.