Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10684 closed defect (invalid)

plot of rational function crashes sage

Reported by: AlexGhitza Owned by: jason, was
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords: plot rational function crash
Cc: jason Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In sage-4.6.1, the following plot command results in a crash:

sage: plot(lambda x: 1/(x^2-0.5^2), (-10, 10), ymin=-5, ymax=5)
/opt/sage/local/bin/sage-sage: line 300:  5596 Illegal instruction      (core dumped) sage-ipython "$@" -i

Note that the following modified version works fine:

sage: plot(lambda x: 1/(x^2-1^2), (-10, 10), ymin=-5, ymax=5)

Change History (9)

comment:1 Changed 10 years ago by aapitzsch

I cannot confirm this crash. Tested with 4.6.2.alpha0.

comment:2 Changed 10 years ago by jason

  • Cc jason added

comment:3 Changed 10 years ago by robert_goss

I cannot confirm this crash either. Testing with 4.6.1 release

comment:4 Changed 10 years ago by jason

I also didn't get a crash for the first plot (OSX 10.6.6, sage-4.6.1). Alex, can you provide more details about your setup?

comment:5 Changed 10 years ago by AlexGhitza

Hmmm. This ticket should definitely be closed as invalid.

I don't actually know what happened. The machine I got this on runs Arch Linux and is rather slow for building sage from scratch, so I have been using the binaries packaged with Arch. Since I ran into the problem there have been a couple of updates for these binaries so maybe something was slightly off and is now ok. Or maybe something else was messed up in my setup and now is back to normal. In any case, I cannot reproduce this anymore.

If someone is really keen on doing detective work on this, I could probably downgrade my sage binaries and try to catch this again.

comment:6 Changed 10 years ago by jason

What do you say we mark it as invalid, with the understanding that you open it again if you see it again. My first inclination is that the binary was built on a processor using processor-specific functionality that your processor did not have. That seems to usually be the cause of the error messages you saw.

comment:7 Changed 10 years ago by jason

I meant, what do you think about marking this ticket as invalid now and opening another one if you see the problem again.

comment:8 Changed 10 years ago by AlexGhitza

  • Resolution set to invalid
  • Status changed from new to closed

Sounds good.

comment:9 Changed 10 years ago by mvngu

  • Milestone changed from sage-4.7 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.