Opened 10 years ago

Closed 10 years ago

#10681 closed defect (fixed)

Tachyon on 32-bit OSX still sets CC=cc

Reported by: vbraun Owned by: tbd
Priority: minor Milestone: sage-4.6.2
Component: packages: standard Keywords:
Cc: wjp, mhampton, wdj Merged in: sage-4.6.2.alpha3
Authors: Volker Braun Reviewers: John Palmieri, Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by vbraun)

I think I forgot to remove this one instance of overwriting CC in tachyon's makefile. In particular, the macosx (not -64) make target. See also

https://groups.google.com/d/msg/sage-release/8zcyl2Q1VvE/usSSY2v3g74J

Updated tachyon spkg is here:

http://www.stp.dias.ie/~vbraun/Sage/spkg/tachyon-0.98.9.p2.spkg

Change History (8)

comment:1 Changed 10 years ago by vbraun

  • Cc wjp mhampton wdj added
  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 10 years ago by jhpalmieri

  • Priority changed from major to minor
  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

On my Mac, with the old version compilation is done with commands like

  cc -Os -ffast-math -DBsd  -DUSEPNG ...

while with the new version, I see

  gcc -Os -ffast-math -DBsd  -DUSEPNG ...

Compilation succeeds in both cases, and tachyon seems to work in both cases.

The spkg looks good, mercurial repo is good -- thanks for checking in the previously unchecked files.

comment:3 follow-up: Changed 10 years ago by vbraun

  • Status changed from positive_review to needs_info

I've updated the spkg to call ranlib libtachyon.a. For some inexplicable reason, the tachyon makefile defaults to not running ranlib. This seems to break at least some Xcode versions.

I've tested the change on my Fedora 14 box, bsd.math (OSX) and t2.math (Solaris). In all cases ranlib works as expected. Not sure why tachyon defaults to not using it...

wdj: This should now definitely fix the "ld: in ../compile/macosx/libtachyon.a, archive has no table of contents" bug. Please confirm.

comment:4 follow-up: Changed 10 years ago by jhpalmieri

It looks like you updated "Make-arch" without updating "Make-arch.patch". Also, is it too drastic to turn ranlib on everywhere, when it used to be off everywhere? Would it be better just to turn it on for macosx? Or maybe just undo the changes for various platforms at #5281 where you removed all of the RANLIB = ... lines?

comment:5 in reply to: ↑ 3 Changed 10 years ago by wdj

Replying to vbraun:

...

wdj: This should now definitely fix the "ld: in ../compile/macosx/libtachyon.a, archive has no table of contents" bug. Please confirm.

Confirmed (on 2 different machines both running mac os 10.6.6) in the sense that both compile now.

comment:6 in reply to: ↑ 4 Changed 10 years ago by vbraun

  • Status changed from needs_info to needs_review

Replying to jhpalmieri:

Also, is it too drastic to turn ranlib on everywhere, when it used to be off everywhere?

I've now removed the default RANLIB setting in the Make-arch completely. Just like CC, the Makefile should just use Sage's RANLIB environment variable. Which happens to be RANLIB=ranlib, so ranlib is run on libtachyon.a.

Right now Sage is already running ranlib (usually via libtool) on pretty much every static library:

[vbraun@volker-two sage]$ grep ranlib install.log  | wc
    274     881   10282

Updated spkg is at the same location. I've also refreshed the Make-arch.patch.

comment:7 Changed 10 years ago by jdemeyer

  • Reviewers changed from John Palmieri to John Palmieri, Jeroen Demeyer
  • Status changed from needs_review to positive_review

Looks fine to me.

comment:8 Changed 10 years ago by jdemeyer

  • Merged in set to sage-4.6.2.alpha3
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.