Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1068 closed defect (duplicate)

turn off inplace optimizations because of numpy problems

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

> The inplace optimizations should be something that have to be
> > explicitly turned on, and they should be off by default.  I know they
> > make certain things faster, but correctness by default is *always* a
> > much more important consideration with serious mathematical software
> > such as Sage.  Always.
> >
> > I will very likely disable in-place optimization for sage-2.8.11,
> > until this issue gets properly discussed and resolved.

:-(, but I have to concede to your logic. The line to change is 148  
of coerce.pxi. Setting this value to 0 will turn them completely off.  
Other than numpy, (and the builtin libraries), do we use any other  
extension types? If there is a finite list of things for which it  
won't work, it would be possible to disable it just for those.

- Robert

Change History (4)

comment:1 Changed 13 years ago by mabshoff

  • Status changed from new to assigned

comment:2 Changed 13 years ago by mabshoff

  • Summary changed from turn off inplace optimizations to turn off inplace optimizations because of numpy problems

comment:3 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.8.11 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from assigned to closed

Oops, dupe of #1018.

Cheers,

Michael

comment:4 Changed 13 years ago by mabshoff

Nope, dupe of #1038!

Note: See TracTickets for help on using tickets.