Opened 11 years ago

Closed 10 years ago

#10678 closed enhancement (fixed)

properly link "derivative" in sage.symbolic.expression.derivative documentation

Reported by: ddrake Owned by: ddrake
Priority: trivial Milestone: sage-5.1
Component: documentation Keywords: symbolic derivative sd40.5
Cc: Merged in: sage-5.1.beta4
Authors: Dan Drake Reviewers: Benjamin Jones
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by benjaminfjones)

Currently, the documentation for the derivative method of symbolic functions says "see documentation for the global derivative() function for more details", with no hyperlink on the derivative. The attached patch fixes that.


Apply to $SAGE_ROOT/devel/sage

Attachments (2)

trac_10678-reviewer.patch (2.4 KB) - added by kcrisman 10 years ago.
trac_10678.2.patch (2.0 KB) - added by ddrake 10 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 11 years ago by ddrake

  • Authors set to Dan Drake
  • Status changed from new to needs_review

comment:2 follow-up: Changed 11 years ago by ddrake

  • Keywords symbolic derivative added

While we're at it, mention that .derivative() is smart for functions of a single variable -- you don't need to supply it.

comment:3 Changed 11 years ago by ddrake

  • Owner changed from mvngu to ddrake

Patchbot (and humans): apply only trac_10678.2.patch

comment:4 in reply to: ↑ 2 ; follow-up: Changed 11 years ago by kcrisman

  • Status changed from needs_review to needs_info

Replying to ddrake:

While we're at it, mention that .derivative() is smart for functions of a single variable -- you don't need to supply it.

Hmm, I'm not sure about doing this. I know you said that elsewhere as well. The problem is that the people (Burcin) who implemented the new stuff are strongly against implied variables. Try the same stuff with f = x^3 + sin(x) and it still works... but I seem to recall that they weren't hot to keep it that way. I have no idea where to look for evidence of this, of course. But putting 'needs info' until that's resolved.

comment:5 in reply to: ↑ 4 Changed 10 years ago by ddrake

Replying to kcrisman:

But putting 'needs info' until that's resolved.

I think that will take too long. Let's forget about that and only use attachment:trac_10678.patch. Let's review that and use it.

Patchbot: apply trac_10678.2.patch

comment:6 Changed 10 years ago by ddrake

  • Status changed from needs_info to needs_review

comment:7 Changed 10 years ago by ddrake

  • Keywords sd40.5 added

comment:8 Changed 10 years ago by benjaminfjones

  • Description modified (diff)
  • Reviewers set to Benjamin Jones
  • Status changed from needs_review to positive_review

Patch looks good and all tests pass when applied to 5.1.beta0. Positive review.

Changed 10 years ago by kcrisman

comment:9 Changed 10 years ago by kcrisman

I checked

sage -docbuild --warn-links reference html

and fixed a few things from that, especially just by adding things to the reference manual. There are two "pickle" ones that won't be fixed, but I can't do anything about those because that file is not ready for the reference manual.

comment:10 Changed 10 years ago by benjaminfjones

Reviewed the new reviewer patch, I reaffirm my previous positive review.

comment:11 Changed 10 years ago by benjaminfjones

  • Description modified (diff)

comment:12 Changed 10 years ago by jdemeyer

  • Status changed from positive_review to needs_work

There are a few warnings when building the reference manual (:method: should be :meth:):

dochtml.log:docstring of sage.symbolic.function.Function:3: ERROR: Unknown interpreted text role "method".
dochtml.log:docstring of sage.symbolic.function.Function:3: ERROR: Unknown interpreted text role "method".
dochtml.log:docstring of sage.symbolic.function.Function:3: ERROR: Unknown interpreted text role "method".

Also, it would be nice to make the heading of sage/sumbolic/function.py consistent with http://sagemath.org/doc/developer/conventions.html#headings-of-sage-library-code-files

Changed 10 years ago by ddrake

comment:13 Changed 10 years ago by ddrake

I fixed the :method: stuff. I think we'll leave the heading for later.

comment:14 Changed 10 years ago by ddrake

  • Status changed from needs_work to needs_review

comment:15 Changed 10 years ago by benjaminfjones

  • Status changed from needs_review to positive_review

Looks good. I re-re-affirm my earlier positive review.

comment:16 Changed 10 years ago by jdemeyer

  • Merged in set to sage-5.1.beta4
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.