Opened 10 years ago

Closed 10 years ago

#10676 closed defect (duplicate)

[duplicate] Bizarre results for genus of a singular curve

Reported by: davidloeffler Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebraic geometry Keywords:
Cc: Merged in:
Authors: Reviewers: David Loeffler
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In vanilla Sage 4.6.1:

sage: R.<x, y, z> = QQ[]
sage: C = Curve(x^2 - 2*y^2)
sage: C.is_singular()
True
sage: C.genus()
4294967295

I'm not quite sure how one defines the genus of a reducible variety, but I'm pretty sure that answer's not right...

(I spotted this during testing #727, but it has nothing to do with conics, of course.)

Change History (4)

comment:1 Changed 10 years ago by lftabera

This is a duplicate of #10308

comment:2 Changed 10 years ago by davidloeffler

  • Milestone changed from sage-4.6.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review
  • Summary changed from Bizarre results for genus of a singular curve to [duplicate] Bizarre results for genus of a singular curve

So it is. Release manager: please close.

comment:3 Changed 10 years ago by davidloeffler

  • Status changed from needs_review to positive_review

comment:4 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to David Loeffler
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.