Opened 10 years ago

Closed 8 years ago

#10608 closed defect (duplicate)

Generating polynomial rings over matrices hangs

Reported by: spancratz Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords: matrix polynomial ring
Cc: Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

As of 4.6.0, the following code hangs:

    sage: MS = MatrixSpace(ZZ, 2, 2)
    sage: R.<x> = MS[]

whereas

    sage: MS = MatrixSpace(ZZ, 2, 2)
    sage: R.<x> = PolynomialRing(MS)

works.

Attachments (1)

trac-10608.patch (3.1 KB) - added by spancratz 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by spancratz

comment:1 Changed 10 years ago by aly.deines

  • Reviewers set to Aly Deines
  • Status changed from new to needs_work

I got the following error on sage-4.6.1.rc1:

rlm-book:sage-4.6.1.rc1 aly$ ./sage -t devel/sage/sage/matrix/matrix_space.py sage -t "devel/sage/sage/matrix/matrix_space.py" File "/Users/aly/Desktop/sage-4.6.1.rc1/devel/sage/sage/matrix/matrix_space.py", line 630:

sage: R.<x> = MS[]

Exception raised:

Traceback (most recent call last):

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/bin/ncadoctest.py", line 1231, in run_one_test

self.run_one_example(test, example, filename, compileflags)

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/bin/sagedoctest.py", line 38, in run_one_example

OrigDocTestRunner?.run_one_example(self, test, example, filename, compileflags)

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/bin/ncadoctest.py", line 1172, in run_one_example

compileflags, 1) in test.globs

File "<doctest main.example_14[6]>", line 1, in <module>

R = MSx?; (x,) = R._first_ngens(1)###line 630:

sage: R.<x> = MS[]

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/lib/python/site-packages/sage/matrix/matrix_space.py", line 655, in getitem

P = PolynomialRing?(self, x)

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/lib/python/site-packages/sage/rings/polynomial/polynomial_ring_constructor.py", line 319, in PolynomialRing?

raise TypeError?, 'base_ring must be a ring'

TypeError?: base_ring must be a ring

File "/Users/aly/Desktop/sage-4.6.1.rc1/devel/sage/sage/matrix/matrix_space.py", line 640:

sage: MSt?

Exception raised:

Traceback (most recent call last):

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/bin/ncadoctest.py", line 1231, in run_one_test

self.run_one_example(test, example, filename, compileflags)

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/bin/sagedoctest.py", line 38, in run_one_example

OrigDocTestRunner?.run_one_example(self, test, example, filename, compileflags)

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/bin/ncadoctest.py", line 1172, in run_one_example

compileflags, 1) in test.globs

File "<doctest main.example_14[8]>", line 1, in <module>

MSt?###line 640:

sage: MSt?

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/lib/python/site-packages/sage/matrix/matrix_space.py", line 682, in getitem

R = P(self, x)

File "/Users/aly/Desktop/sage-4.6.1.rc1/local/lib/python/site-packages/sage/rings/power_series_ring.py", line 211, in PowerSeriesRing?

raise TypeError?, "base_ring must be a commutative ring"

TypeError?: base_ring must be a commutative ring

1 items had failures:

2 of 9 in main.example_14

*Test Failed* 2 failures. For whitespace errors, see the file /Users/aly/.sagetmp/.doctest_matrix_space.py

[19.8 s]


The following tests failed:

sage -t "devel/sage/sage/matrix/matrix_space.py"

Total time for all tests: 19.9 seconds

comment:2 Changed 8 years ago by tscrim

  • Component changed from user interface to website/wiki
  • Milestone changed from sage-5.9 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to needs_review

This is a duplicate of #8389.

comment:3 Changed 8 years ago by tscrim

  • Authors spancratz deleted
  • Component changed from website/wiki to algebra
  • Reviewers changed from Aly Deines to Travis Scrimshaw

comment:4 Changed 8 years ago by mhansen

  • Resolution set to duplicate
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.