Changes between Version 14 and Version 16 of Ticket #10469


Ignore:
Timestamp:
03/27/11 21:05:29 (11 years ago)
Author:
jdemeyer
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #10469

    • Property Status changed from needs_review to needs_work
  • Ticket #10469 – Description

    v14 v16  
    3535----
    3636
    37 Also, we should replace the useless
    38 {{{
    39 #!sh
    40 #!/usr/bin/env bash
    41 }}}
    42 at its top by (e.g.)
    43 {{{
    44 #!sh
    45 #!/this/script/must/be/sourced
    46 }}}
    47 which causes an error if `sage-env` is called rather than sourced (which makes no sense and therefore ''is'' indeed an error), with an "appropriate" error message since such an interpreter certainly does not exist.
     37Also, we should change the permissions of `sage-env` to non-executable (it must be ''sourced'', not executed).
    4838
    49 Apply trac_10469.v5[1].patch to local/bin
     39Apply [attachment:trac_10469.v5[1].patch] to local/bin