Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#10434 closed enhancement (fixed)

add doctests from #8582 and other integration improvements from Maxima 5.22.1

Reported by: mvngu Owned by: mvngu
Priority: major Milestone: sage-4.6.1
Component: documentation Keywords:
Cc: burcin, jason Merged in: sage-4.6.1.rc0
Authors: Minh Van Nguyen Reviewers: Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by mvngu)

This is a follow-up to ticket #10187. Tickets #8582 and #8624 have many useful doctests to ensure that the upgrade to Maxima 5.22.1 fixes many reported issues. Add those doctests.

Attachments (1)

trac-10434_doctests.patch (1.9 KB) - added by mvngu 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by mvngu

  • Description modified (diff)

comment:2 Changed 9 years ago by burcin

  • Cc burcin added

Changed 9 years ago by mvngu

comment:3 Changed 9 years ago by mvngu

  • Authors set to Minh Van Nguyen
  • Status changed from new to needs_review

In Sage 4.6.1.alpha3, I cannot/don't know how to reproduce the following:

sage: integrate(sqrt(x + sqrt(x)), x).simplify_full() 
1/12*sqrt(sqrt(x) + 1)*((8*x - 3)*x^(1/4) + 2*x^(3/4)) - 1/8*log(sqrt(sqrt(x) + 1) - x^(1/4)) + 1/8*log(sqrt(sqrt(x) + 1) + x^(1/4))

I left out the remaining doctests from http://trac.sagemath.org/sage_trac/raw-attachment/ticket/8624/trac-8624-abs-integration.patch because those, I think, haven't resulted in failures.

comment:4 follow-up: Changed 9 years ago by kcrisman

I really hate opening new tickets... makes it look like we're making Sage better than is actually true. Anyway, once I get the chance to upgrade I will take a look at this.

comment:5 in reply to: ↑ 4 Changed 9 years ago by burcin

  • Cc jason added

Replying to kcrisman:

I really hate opening new tickets... makes it look like we're making Sage better than is actually true. Anyway, once I get the chance to upgrade I will take a look at this.

I agree. I would have preferred to close those tickets after merging patches with doctests as well.

In this case, I think we should still reopen #8624 and change the summary to "enable abs_integrate package from maxima".

comment:6 Changed 9 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman
  • Status changed from needs_review to positive_review
  • Summary changed from add doctests from #8624 and #8582 to add doctests from #8582 and other integration improvements from Maxima 5.22.1

Okay, correctly checks #8582 and does the right stuff from #8624 that we need. I agree with Minh that the other stuff was not needed.

Very odd about the sqrt(x+sqrt(x)) thing. I think that Burcin is right; we never enabled the abs integrate - Maxima just got better at the #8624 integrals on its own:

Maxima 5.22.1 http://maxima.sourceforge.net
using Lisp ECL 10.4.1
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
The function bug_report() provides bug reporting information.
(%i1) integrate(abs(cos(x))*sin(x),x,%pi/2,%pi);
                                       1
(%o1)                                  -
                                       2

So I respectfully request that someone with the authority reopen that ticket as he suggests, with new title. Using abs_integrate does solve the square root integral in question (sqrt(x+sqrt(x))).

However, I think that this one can still be merged, since there are no problems with these, and they were verified as correct on the relevant tickets, and it passes the tests, of course, and applies, of course.

To release manager/patchbot: doc fix only, apply trac-10434_doctests.patch

comment:7 Changed 9 years ago by jdemeyer

  • Merged in set to sage-4.6.1.rc0
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:8 Changed 8 years ago by kcrisman

See also #11483 for the abs_integrate stuff.

Note: See TracTickets for help on using tickets.