Opened 11 years ago

Closed 10 years ago

#10361 closed enhancement (duplicate)

upgrade setuptools to 0.6c11

Reported by: Koen Owned by: tbd
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: distribute
Cc: jsp Merged in:
Authors: Reviewers: Mariah Lenox
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The current setuptools version in Sage is 0.6c9. However, in the 0.6c11 update, there's an important change:

 * Fixes for various dependency management problems such as looping builds, 
   re-downloading packages already present on sys.path (but not in a registered
   "site" directory), and semi-randomly preferring local "-f" packages over
   local installed packages

The problem in the PyCUDA package with a corrupted setuptools ( http://trac.sagemath.org/sage_trac/ticket/10010 ) after installing distribute is caused due to this outdated setuptools version.

The package is really simple (like the current 0.6c9 package), because it has no patches compared to the vanilla setuptools from http://pypi.python.org/pypi/setuptools . Therefore, I just copied in the new source and that was it.

Attachments (1)

trac_10361-fix_spkg-install-spkg.patch (772 bytes) - added by leif 11 years ago.
SPKG patch. Adds error checking etc.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 11 years ago by Koen

  • Priority changed from major to critical
  • Status changed from new to needs_review

comment:2 follow-up: Changed 11 years ago by leif

  • Authors set to Keshav Kini
  • Keywords distribute added

(Almost) regardless of its size, never attach a binary file on trac... ;-)

Instead, put a link to it on the ticket, and perhaps attach an spkg diff or Mercurial patch to the ticket for reference / review.

If you don't have a sagemath account (or some other place to upload it), you can use http://code.google.com/p/spkg-upload/ .

I think I've already made such an spkg IIRC, with further clean-up a while ago. Let me see...

comment:3 in reply to: ↑ 2 Changed 11 years ago by leif

Replying to leif:

I think I've already made such an spkg IIRC, with further clean-up a while ago. Let me see...

Ah, no. I looked at the 0.6c11, but did not make a new spkg, but only patched the 0.6c9 with some "debug" code, adding more messages regarding the handling of .pth files with which we had trouble.

I'll take a look at your spkg.

Changed 11 years ago by leif

SPKG patch. Adds error checking etc.

comment:4 Changed 11 years ago by leif

  • Authors changed from Keshav Kini to Koen van de Sande, Leif Leonhardy

I've attached a patch to spkg-install.

Koen: You haven't updated SPKG.txt.

(I haven't either.) Can you do that and provide an updated spkg somewhere else (with also my patch applied)?

I'll then ask someone powerful to remove the spkg attached to the ticket.

(P.S.: Sorry, confused your name...)

comment:5 Changed 11 years ago by leif

Besides applying the patch, you apparently also have to

chmod +x spkg-install

again.

comment:6 Changed 11 years ago by leif

Also, please delete Michael Abshoff from the spkg maintainer list in SPKG.txt, and

rm setuptools-0.6c11.p0/src/setuptools/gui.exe
rm setuptools-0.6c11.p0/src/setuptools/cli.exe

A comment on this should go into the (not yet existing) Special Update/Build? Instructions section.

comment:7 Changed 11 years ago by leif

  • Cc jsp added

CC'ing the remaining spkg maintainer...

comment:8 follow-up: Changed 11 years ago by Koen

Here's the updated package: http://code.google.com/p/spkg-upload/downloads/detail?name=setuptools-0.6c11.p0.spkg Also, I'm under the impression that SPKG.txt/spkg-install are under version control somewhere. Note that I modified the files and haven't committed them anywhere.

comment:9 in reply to: ↑ 8 Changed 11 years ago by leif

Replying to Koen:

Also, I'm under the impression that SPKG.txt/spkg-install are under version control somewhere. Note that I modified the files and haven't committed them anywhere.

Somewhere? :)

Every spkg has its Mercurial repository (.hg), which contains the Sage part of the spkg, but not the upstream code (src/, which is in .hgignore).

So you just have to hg commit and provide a commit message, starting with the ticket number (#10361), and a brief (one-line) description. (You can optionally in addition provide a longer description, e.g. a copy of your Changelog entry, below that first and a blank line.)

You may have to create/edit your ~/.hgrc first, such that Mercurial adds the proper name and e-mail address.

I'll see how you applied my patch without using Mercurial(?)... You should have perhaps first updated SPKG.txt, committed your changes, and then hg import /path/to/my/patch.

comment:10 Changed 11 years ago by leif

P.S.:

In case you want to update your spkg at spkg-upload, first delete the old one, then you can (re-)upload a new one with the same name.

We usually provide the md5sum of an spkg along with the (raw) download link on the ticket, (also) to avoid confusion with previous versions.

comment:11 follow-up: Changed 11 years ago by Koen

OK, this time by using version control (I didn't realize the complete repository is in the spkg, I thought there was a centralized repository somewhere).

http://spkg-upload.googlecode.com/files/setuptools-0.6c11.p0.spkg SHA1 Checksum: bd8a3be6200f66163ab51ec2c08b9a10cb46fc7f

comment:12 in reply to: ↑ 11 Changed 11 years ago by leif

  • Reviewers set to Leif Leonhardy

Replying to Koen:

OK, this time by using version control (I didn't realize the complete repository is in the spkg, I thought there was a centralized repository somewhere).

http://spkg-upload.googlecode.com/files/setuptools-0.6c11.p0.spkg SHA1 Checksum: bd8a3be6200f66163ab51ec2c08b9a10cb46fc7f

Ok, the .exe files are back, but they're quite small (8 KB each).

The changelog entry should name the whole spkg (base)name (i.e. setuptools-0.6c11.p0), and it's convenient to also have the ticket number in the changelog, but I don't mind.

I've tested it with both Sage 4.6.1.alpha2 and alpha3, also by reinstalling SageNB (which uses setuptools).

So if you are ok with my changes, too, we have a positive review.

comment:13 Changed 11 years ago by drkirkby

I'm responding to Leif's email for the .spkg to be deleted, so I've done it.

Note, that .spkg's should never be attached to trac. The system is not set up to handle large files, which .spkg's generally are. (In fact, I've lost count the number of times trac stops working because a file system is full)

Please instead put them on a server of some sort and provide a link with and ideally state the md5 checksum too.

Note William will give any Sage developer an account on the *.math.washington.edu network. Since your home directory is then publicly readable, just stick .spkg's in your home directory, or probably more logically make a sub-directory and stick them there.

Here's my directory - I should clean some of the older ones out!

http://boxen.math.washington.edu/home/kirkby/patches/

Dave

comment:14 Changed 11 years ago by Koen

  • Reviewers changed from Leif Leonhardy to Leif Leonhardy, Koen van de Sande
  • Status changed from needs_review to positive_review

I'm ok with the changes by Leif, so we're now at positive review.

comment:15 Changed 11 years ago by jdemeyer

  • Milestone changed from sage-4.6.1 to sage-4.6.2

comment:16 Changed 11 years ago by jdemeyer

  • Merged in set to sage-4.6.2.alpha1
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:17 Changed 11 years ago by jdemeyer

  • Merged in sage-4.6.2.alpha1 deleted
  • Resolution fixed deleted
  • Status changed from closed to new

Could this cause twisted to fail to install on bsd.math (OS X)?

comment:18 Changed 11 years ago by jdemeyer

  • Status changed from new to needs_work

comment:19 Changed 11 years ago by jdemeyer

  • Work issues set to breaks twisted on OS X??

comment:20 Changed 11 years ago by jdemeyer

  • Work issues changed from breaks twisted on OS X?? to breaks twisted on OS X

Confirmed that this new spkg actually breaks building twisted on bsd.math.

comment:21 Changed 10 years ago by jdemeyer

  • Authors Koen van de Sande, Leif Leonhardy deleted
  • Milestone changed from sage-4.7.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers changed from Leif Leonhardy, Koen van de Sande to Mariah Lenox
  • Status changed from needs_work to closed
  • Work issues breaks twisted on OS X deleted

See #11363 instead.

Note: See TracTickets for help on using tickets.