Opened 9 years ago

Closed 4 weeks ago

#10357 closed enhancement (duplicate)

merge_vertices does not respect loops

Reported by: jason Owned by: jason, ncohen, rlm
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: graph theory Keywords:
Cc: Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by gh-kliem)

This is a duplicate of #9807.

If a graph allows loops, then merge_vertices maybe should have an option to put a loop on the merged vertex if there was either an edge between the vertices, or maybe if the merged vertices formed a complete graph, so the following would make a loop in the graph:

g=graphs.PathGraph(2)
g.allow_loops(True)
g.merge_vertices([0,1])
g.edges()

In my case, I'm merging two vertices, so either case would be the same thing.

Change History (10)

comment:1 Changed 9 years ago by jason

  • Description modified (diff)

comment:2 Changed 9 years ago by mvngu

  • Status changed from new to needs_info

Is this a duplicate of #9807?

comment:3 Changed 8 years ago by brunellus

Yes. Also, see #7304.

comment:4 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:5 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:6 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:7 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:8 Changed 5 weeks ago by gh-kliem

  • Description modified (diff)
  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from needs_info to needs_review

This is a duplicate of #9807.

comment:9 Changed 4 weeks ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

Agreed.

comment:10 Changed 4 weeks ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.