Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10282 closed defect (duplicate)

Discrepancy in symbol ordering in multiplication

Reported by: kcrisman Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: burcin, jpflori Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

For some reason Macs and other systems do not agree on the following. See #10187 for the genesis of this.

Mac:

sage: psi(1,1/3)*log(3)
log(3)*psi(1, 1/3)

Other (at least Linux and some Solaris, I guess):

sage: psi(1,1/3)*log(3)
psi(1, 1/3)*log(3)

I thought it was a Pynac thing, but maybe not:

sage: from sage.misc.citation import get_systems
sage: get_systems('psi(1,1/3)*log(3)')
['GMP']

Based on that, putting component 'basic arithmetic', but cc:ing Burcin in case it's Pynac after all.

Change History (3)

comment:1 follow-up: Changed 9 years ago by burcin

  • Cc jpflori added
  • Component changed from basic arithmetic to symbolics
  • Milestone set to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

I'm pretty sure this is a duplicate of #9632. It should be fixed by Jean-Pierre Flori's patch attached to #9880. Unfortunately I am very busy these days and I probably won't have time to review that until January.

If somebody else can review the changes for pynac, I'd be happy to make a new release with those patches, and a couple of others I've merged from upstream fixes in the meantime.

comment:2 in reply to: ↑ 1 Changed 9 years ago by kcrisman

Replying to burcin:

I'm pretty sure this is a duplicate of #9632. It should be fixed by Jean-Pierre Flori's patch attached to #9880. Unfortunately I am very busy these days and I probably won't have time to review that until January.

Thanks, you are almost certainly correct.

If somebody else can review the changes for pynac, I'd be happy to make a new release with those patches, and a couple of others I've merged from upstream fixes in the meantime.

I'll try to do this as I have the opportunity over the next week or so. This is pretty important, in my opinion. Thanks for noticing this!

comment:3 Changed 9 years ago by jpflori


As noted by Burcin, it is related to pynac ordering and applying the patch I provided in #9880 gives me a consistent behavior on Mac and Linux:

sage: psi(1,1/3)*log(3)
log(3)*psi(1, 1/3)


(I order the functions according to their name in lexicographic order)

However #9880 still needs a lot of work:

- my patch must be reviewed

- pynac must be updated

- a lot of doctests will have to be fixed afterwards

Note: See TracTickets for help on using tickets.