Opened 10 years ago

Closed 10 years ago

#10235 closed defect (duplicate)

singular-3-1-1-4.p3 is missing Singular.rc.in

Reported by: mhansen Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords: singular, cygwin
Cc: malb, dimpase, mhansen Merged in:
Authors: Karl-Dieter Crisman Reviewers: Leif Leonhardy
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #11550 Stopgaps:

Status badges

Description

This is needed in order to build Singular on Cygwin. It has been in previous releases, but I don't know why it is gone now. This has happened before; see:

http://www.mail-archive.com/sage-devel@googlegroups.com/msg02800.html

and

http://www.mail-archive.com/sage-devel@googlegroups.com/msg02767.html

Change History (16)

comment:1 Changed 10 years ago by kcrisman

Another ticket related to this issue is #11550. Not recommending to close this until we're sure this is all the same.

comment:2 Changed 10 years ago by kcrisman

  • Cc dimpase mhansen added

I can confirm that Singular builds and works fine (via sage -singular, computed the free resolution of an ideal) on Cygwin with the fix at #11550. Should this be closed?

comment:3 follow-up: Changed 10 years ago by kcrisman

  • Component changed from packages to cygwin

I'm going to leave this open because it might be needed later, but for now I'm removing it from the list of needed changes on the wiki page for Cygwin because it's apparently not an issue right now.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 10 years ago by leif

  • Status changed from new to needs_info

Replying to kcrisman:

I'm going to leave this open because it might be needed later, but for now I'm removing it from the list of needed changes on the wiki page for Cygwin because it's apparently not an issue right now.

Well, the file is at least present in the p9 (and I guess also in your p10), so if the potential problem is documented in Singular's SPKG.txt (Special Update/Build? Instructions), I think we should close this ticket.

comment:5 in reply to: ↑ 4 Changed 10 years ago by kcrisman

Replying to leif:

Replying to kcrisman:

I'm going to leave this open because it might be needed later, but for now I'm removing it from the list of needed changes on the wiki page for Cygwin because it's apparently not an issue right now.

Well, the file is at least present in the p9 (and I guess also in your p10), so if the potential problem is documented in Singular's SPKG.txt (Special Update/Build? Instructions), I think we should close this ticket.

Yes, I just checked and it is indeed in there (in the src/Singular/ directory, where I hadn't looked beforehand, only toplevel).

However, this is only mentioned in one place in the SPKG.txt, just as an update from four years ago, so I would say that solving this requires changing SPKG.txt to mention this, as you say. However, that could in principle be added in some other ticket, so as not to multiply p's beyond belief.

comment:6 follow-up: Changed 10 years ago by kcrisman

  • Authors set to Karl-Dieter Crisman
  • Status changed from needs_info to needs_review

Okay, I've included a comment to this effect in the p11 for #11550 (that spkg does have this file). I suppose one would review this by checking that that spkg has that comment in the correct place.

comment:7 in reply to: ↑ 6 Changed 10 years ago by leif

Replying to kcrisman:

Okay, I've included a comment to this effect in the p11 for #11550 (that spkg does have this file). I suppose one would review this by checking that that spkg has that comment in the correct place.

Another thing would be to just check in spkg-install (at least on Cygwin) that

  • the file is present in the upstream sources, and / or
  • the file generated from it indeed did get installed (as Singular.rc I guess). [Where does this file get installed to / where is it supposed to be located? I think I don't have such on Linux.]

comment:8 follow-up: Changed 10 years ago by kcrisman

I don't know the answer to your questions, and while I know that something like [ -x file] (?) would do this. I don't know anything else about this file. Apparently it is in the upstream sources. It lives in src/Singular/. I feel like that is more than needed for this; the perfect will otherwise become the enemy of the done.

comment:9 in reply to: ↑ 8 ; follow-up: Changed 10 years ago by leif

Replying to kcrisman:

I don't know the answer to your questions, and while I know that something like [ -x file] (?) would do this. I don't know anything else about this file. Apparently it is in the upstream sources. It lives in src/Singular/. I feel like that is more than needed for this; the perfect will otherwise become the enemy of the done.

Wie Du weisst, der Feind des Guten ist das Bessere... ;-)

But you could just search for a file named Singular.rc or singular.rc on your Cygwin installation, since if Singular there doesn't work without its template file, there must be something installed which was generated from it, perhaps in your Cygwin home directory or somewhere in $SAGE_LOCAL/share/singular, or $SAGE_LOCAL/bin.

(spkg/logs/singular-*.log perhaps gives some hint.)

I won't object giving this ticket a positive review when a positively reviewed p11 at #11550 has just the comment you added in SPKG.txt. I don't care much about Cygwin anyway... B)

comment:10 follow-up: Changed 10 years ago by kcrisman

There is now something to review at #11550. It's the same as it was, except now based on #11563 and #11645, in principle.

comment:11 in reply to: ↑ 10 Changed 10 years ago by kcrisman

Replying to kcrisman:

There is now something to review at #11550. It's the same as it was, except now based on #11563 and #11645, in principle.

I mean #11663 and #11645, of course.

comment:12 in reply to: ↑ 9 Changed 10 years ago by kcrisman

I won't object giving this ticket a positive review when a positively reviewed p11 at #11550 has just the comment you added in SPKG.txt.

Okay, the spkg at #11550 is now based on the spkgs in rc2 and it's ready for review that it includes this comment. Thanks!

comment:13 follow-up: Changed 10 years ago by leif

  • Dependencies set to #11550
  • Reviewers set to Leif Leonhardy
  • Status changed from needs_review to positive_review

Provisional positive review; I'll revert the status in case something unexpected should happen with the p13 at #11550 (which I've added as a dependency anyway).

P.S.: I also checked that the build on Cygwin should fail in the case Singular.rc.in was not present.

comment:14 in reply to: ↑ 13 ; follow-up: Changed 10 years ago by kcrisman

P.S.: I also checked that the build on Cygwin should fail in the case Singular.rc.in was not present.

Really? How? You mean in spkg-install? I don't see anything relevant there. Did you trace through the actual Singular build scripts? Hut ab!

comment:15 in reply to: ↑ 14 Changed 10 years ago by leif

Replying to kcrisman:

Did you trace through the actual Singular build scripts? Hut ab!

Singular.rc depends on, i.e. is generated from Singular.rc.in; the former is used to generate some object files with windres on Cygwin / Windows ({Singular,ESingular,TSingular}_res.o), which are then linked to the executables (Singular.exe, runESingular.exe and runTSingular.exe).

grep is your friend.

comment:16 Changed 10 years ago by jdemeyer

  • Milestone changed from sage-4.7.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.