Opened 7 years ago

Closed 6 years ago

#10171 closed defect (fixed)

sage -hg serve is completely broken on OS X

Reported by: was Owned by: jason
Priority: major Milestone: sage-5.0
Component: misc Keywords:
Cc: jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

On OS X with a fresh install of Sage:

wstein@bsd:~/build/sage-4.5.3/devel/sage/sage$ sage -hg serve -p 8200

In another window type

wstein@bsd:~$ open  http://localhost:8200

And in the first window see:

/Users/was/build/sage-4.5.3/local/bin/sage-sage: line 440: 49631 Trace/BPT trap          hg "$@"

The same happens with sage-4.6.alpha3 and port 8000.

This is not a problem on Linux. It's only on OS X, as far as I can tell.

The solution to this is probably the same as for #6440 -- which is Upgrade Mercurial. The version in Sage is ancient -- 1.3.1 -- but the current version of Mercurial is version 1.6.4. That said, I just tried upgrading (which is really confusing, since mercurial is in local/lib/python/, not in local/lib/python/site-packages), and still get the problem:

deep:notes wstein$ psage -hg version
Mercurial Distributed SCM (version 1.6.4)

Copyright (C) 2005-2010 Matt Mackall <mpm@selenic.com> and others
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
deep:notes wstein$ psage -hg serve -p 8200
/Users/wstein/purple/psage-10.09.30/local/bin/sage-sage: line 440: 79089 Trace/BPT trap          hg "$@"

However, installing Mercurial into my systemwide Python works fine. So I don't know what is messed up about Sage's Python.

Change History (10)

comment:1 Changed 7 years ago by jhpalmieri

  • Cc jhpalmieri added

comment:2 in reply to: ↑ description Changed 7 years ago by dimpase

  • Status changed from new to needs_info

Replying to was:

On OS X with a fresh install of Sage:

 deep:notes wstein$ psage -hg version
 Mercurial Distributed SCM (version 1.6.4)
 
 Copyright (C) 2005-2010 Matt Mackall <mpm@selenic.com> and others
 This is free software; see the source for copying conditions. There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 deep:notes wstein$ psage -hg serve -p 8200
 /Users/wstein/purple/psage-10.09.30/local/bin/sage-sage: line 440: 79089 Trace/BPT trap          hg "$@"

I cannot reproduce this on OSX 10.6.7 and Sage-4.7.alpha3. It works for me as it should. Just in case, I have all Sharing settings turned off.

comment:3 Changed 7 years ago by jhpalmieri

It's working for me right now, too.

comment:4 Changed 6 years ago by kcrisman

Also works for me. John, Dima, should we mark this as positive review so Jeroen can close it? I do remember this not working for a while, but just tried it out. Which is great, because it is so useful!

comment:5 Changed 6 years ago by jhpalmieri

For what it's worth, I'm seeing this problem again, with various versions of Sage (e.g., 4.7 and 4.7.1.alpha2) and various versions of mercurial (1.6.4 and 1.8.4 (see #10594).

comment:6 Changed 6 years ago by was

"sage -hg serve -p 8200" works perfectly for me right now with sage-5.0.beta2 on OS X 10.7 with hg 1.8.4. Should we close this?

comment:7 follow-up: Changed 6 years ago by jhpalmieri

Hmm. sage -hg serve -p 8200 doesn't do anything for me: it just sits there. sage -hg serve prints out

listening at http://1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa:8000/ (bound to *:8000)

which looks sort of strange. It also doesn't open up a browser or do anything else.

comment:8 in reply to: ↑ 7 Changed 6 years ago by was

Replying to jhpalmieri:

Hmm. sage -hg serve -p 8200 doesn't do anything for me: it just sits there.

You have to browse to http://localhost:8200. Did that work?

sage -hg serve prints out

listening at http://1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa:8000/ (bound to *:8000)

which looks sort of strange. It also doesn't open up a browser or do anything else.

Popping open a browser, etc., is all stuff I wrote specially for the notebook. I doubt moinmoin has that functionality. It could be added...

Anyway, I seem to recall there was a discussion on sage-devel about removing moinmoin from sage, which would make this ticket invalid.

-- William

comment:9 Changed 6 years ago by jhpalmieri

I thought I remembered it opening a browser before. Anyway, going to localhost:8200 works for me, so let's close the ticket.

comment:10 Changed 6 years ago by was

  • Resolution set to fixed
  • Status changed from needs_info to closed
Note: See TracTickets for help on using tickets.