Ticket #9808: trac_9808-scipy.patch

File trac_9808-scipy.patch, 1.5 KB (added by jhpalmieri, 11 years ago)

for reference only: diff between old scipy 0.8 spkg and new one

  • SPKG.txt

    # HG changeset patch
    # User J. H. Palmieri <palmieri@math.washington.edu>
    # Date 1287085991 25200
    # Node ID a628406ea1d1dacbd6f39a90866748c55a34c9a0
    # Parent  44ee8131ef745688df4b4c191da0f67320853618
    #9808: changed first line of spkg-install from "#!/bin/sh" to
    "#!/usr/bin/env bash": otherwise, it fails to build on Solaris.
    
    diff -r 44ee8131ef74 -r a628406ea1d1 SPKG.txt
    a b BSD terms. See http://www.scipy.org/Lice 
    3232
    3333== Changelog ==
    3434
    35 == scipy-0.8 (S. Reiterer, F. Bissey, D. Kirkby; 6th October 2010) ===
     35== scipy-0.8 (S. Reiterer, F. Bissey, D. Kirkby, J. H. Palmieri; 14 October 2010) ===
    3636 * #9808 Upgrade to scipy 0.8.
    3737 * Deleted outdated patches
    3838 * spkg install changed by F. Bissey, because g95 makes trouble on OS X.
    BSD terms. See http://www.scipy.org/Lice 
    4444   "Special Update/Build Instructions" section to SPKG.txt
    4545 * Changed "maintainer" to "SPKG Maintainers" in SPKG.txt to be consistent with
    4646   what is stated in the Sage Developers Guide.
     47 * In spkg-install, changed first line from "#!/bin/sh" to
     48   "#!/usr/bin/env bash": otherwise, it fails to build on Solaris.
    4749
    4850=== scipy-0.7.1 (Jason Grout; 12 Nov 2009) ===
    4951 * upgrade to scipy 0.7.1.  The optimize.py patch still needs to be applied in this version of scipy.
  • spkg-install

    diff -r 44ee8131ef74 -r a628406ea1d1 spkg-install
    a b  
    1 #!/bin/sh
     1#!/usr/bin/env bash
    22# These flags confuse numpy's distutils.   In particular,
    33# if they are set empty bad things happen.
    44