Ticket #9562: m4rie_spkg.patch

File m4rie_spkg.patch, 1.6 KB (added by malb, 8 years ago)

apply to root repository not to normal Sage repository

  • spkg/install

    # HG changeset patch
    # User Martin Albrecht <martinralbrecht@googlemail.com>
    # Date 1309970853 -7200
    # Node ID 73b2e1362c68512d239bd0fc4593ff6ac3f05420
    # Parent  30ab2964baa48dc3b3987c8ad1d1e701d1a5ea60
    #9562 add m4rie to Sage's dependency tree
    
    diff -r 30ab2964baa4 -r 73b2e1362c68 spkg/install
    a b  
    226226LIBM4RI=`$newest libm4ri`
    227227export LIBM4RI
    228228
     229LIBM4RIE=`$newest libm4rie`
     230export LIBM4RIE
     231
    229232FORTRAN=`$newest fortran`
    230233export FORTRAN
    231234
  • spkg/standard/deps

    diff -r 30ab2964baa4 -r 73b2e1362c68 spkg/standard/deps
    a b  
    7272     $(INST)/$(LIBGCRYPT) \
    7373     $(INST)/$(LIBGPG_ERROR) \
    7474     $(INST)/$(LIBM4RI) \
     75     $(INST)/$(LIBM4RIE) \
    7576     $(INST)/$(LIBPNG) \
    7677     $(INST)/$(LINBOX) \
    7778     $(INST)/$(MATPLOTLIB) \
     
    401402$(INST)/$(LIBM4RI): $(BASE) $(INST)/$(PATCH)
    402403        $(INSTALL) "$(SAGE_SPKG) $(LIBM4RI) 2>&1" "tee -a $(SAGE_LOGS)/$(LIBM4RI).log"
    403404
     405$(INST)/$(LIBM4RIE): $(BASE) $(INST)/$(PATCH) $(INST)/$(LIBM4RI)
     406        $(INSTALL) "$(SAGE_SPKG) $(LIBM4RIE) 2>&1" "tee -a $(SAGE_LOGS)/$(LIBM4RIE).log"
     407
    404408# zn_poly really does depend on Python, despite this is far from obvious.
    405409# The 'configure' script in zn_poly calls Python to make a 'makefile'.
    406410$(INST)/$(ZNPOLY): $(BASE) $(INST)/$(MPIR) $(INST)/$(PYTHON) $(INST)/$(PATCH)
     
    476480                 $(INST)/$(IPYTHON) \
    477481                 $(INST)/$(LCALC) \
    478482                 $(INST)/$(LIBM4RI) \
     483                 $(INST)/$(LIBM4RIE) \
    479484                 $(INST)/$(LINBOX) \
    480485                 $(INST)/$(MATPLOTLIB) \
    481486                 $(INST)/$(MERCURIAL) \