Ticket #21598: psutil-4.3.1.log

File psutil-4.3.1.log, 4.7 KB (added by embray, 6 years ago)
Line 
1Found local metadata for psutil-4.3.1
2Attempting to download package psutil-4.3.1.tar.gz from mirrors
3http://www.mirrorservice.org/sites/www.sagemath.org/spkg/upstream/psutil/psutil-4.3.1.tar.gz
4[......................................................................]
5psutil-4.3.1
6====================================================
7Setting up build directory for psutil-4.3.1
8Finished extraction
9****************************************************
10Host system:
11CYGWIN_NT-10.0 NAVI-Brick 2.5.1(0.297/5/3) 2016-04-21 22:14 x86_64 Cygwin
12****************************************************
13C compiler: gcc
14C compiler version:
15Using built-in specs.
16COLLECT_GCC=gcc
17COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/5.4.0/lto-wrapper.exe
18Target: x86_64-pc-cygwin
19Configured with: /cygdrive/i/szsz/tmpp/gcc/gcc-5.4.0-1.x86_64/src/gcc-5.4.0/configure --srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-5.4.0-1.x86_64/src/gcc-5.4.0 --prefix=/usr --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc --docdir=/usr/share/doc/gcc --htmldir=/usr/share/doc/gcc/html -C --build=x86_64-pc-cygwin --host=x86_64-pc-cygwin --target=x86_64-pc-cygwin --without-libiconv-prefix --without-libintl-prefix --libexecdir=/usr/lib --enable-shared --enable-shared-libgcc --enable-static --enable-version-specific-runtime-libs --enable-bootstrap --enable-__cxa_atexit --with-dwarf2 --with-tune=generic --enable-languages=ada,c,c++,fortran,lto,objc,obj-c++ --enable-graphite --enable-threads=posix --enable-libatomic --enable-libcilkrts --enable-libgomp --enable-libitm --enable-libquadmath --enable-libquadmath-support --enable-libssp --enable-libada --enable-libgcj-sublibs --disable-java-awt --disable-symvers --with-ecj-jar=/usr/share/java/ecj.jar --with-gnu-ld --with-gnu-as --with-cloog-include=/usr/include/cloog-isl --without-libiconv-prefix --without-libintl-prefix --with-system-zlib --enable-linker-build-id --with-default-libstdcxx-abi=gcc4-compatible
20Thread model: posix
21gcc version 5.4.0 (GCC)
22****************************************************
23Ignoring indexes: https://pypi.python.org/simple
24Processing /home/embray/src/sagemath/sage/local/var/tmp/sage/build/psutil-4.3.1/src
25  Running setup.py (path:/tmp/pip-AYThFv-build/setup.py) egg_info for package from file:///home/embray/src/sagemath/sage/local/var/tmp/sage/build/psutil-4.3.1/src
26    Running command python setup.py egg_info
27    platform cygwin is not supported
28Cleaning up...
29Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-AYThFv-build/
30Exception information:
31Traceback (most recent call last):
32  File "/home/embray/src/sagemath/sage/local/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
33    status = self.run(options, args)
34  File "/home/embray/src/sagemath/sage/local/lib/python2.7/site-packages/pip/commands/install.py", line 299, in run
35    requirement_set.prepare_files(finder)
36  File "/home/embray/src/sagemath/sage/local/lib/python2.7/site-packages/pip/req/req_set.py", line 370, in prepare_files
37    ignore_dependencies=self.ignore_dependencies))
38  File "/home/embray/src/sagemath/sage/local/lib/python2.7/site-packages/pip/req/req_set.py", line 601, in _prepare_file
39    abstract_dist.prep_for_dist()
40  File "/home/embray/src/sagemath/sage/local/lib/python2.7/site-packages/pip/req/req_set.py", line 127, in prep_for_dist
41    self.req_to_install.run_egg_info()
42  File "/home/embray/src/sagemath/sage/local/lib/python2.7/site-packages/pip/req/req_install.py", line 425, in run_egg_info
43    command_desc='python setup.py egg_info')
44  File "/home/embray/src/sagemath/sage/local/lib/python2.7/site-packages/pip/utils/__init__.py", line 718, in call_subprocess
45    % (command_desc, proc.returncode, cwd))
46InstallationError: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-AYThFv-build/
47
48real    0m2.640s
49user    0m0.811s
50sys     0m1.340s
51************************************************************************
52Error installing package psutil-4.3.1
53************************************************************************
54Please email sage-devel (http://groups.google.com/group/sage-devel)
55explaining the problem and including the relevant part of the log file
56  /home/embray/src/sagemath/sage/logs/pkgs/psutil-4.3.1.log
57Describe your computer, operating system, etc.
58If you want to try to fix the problem yourself, *don't* just cd to
59/home/embray/src/sagemath/sage/local/var/tmp/sage/build/psutil-4.3.1 and type 'make' or whatever is appropriate.
60Instead, the following commands setup all environment variables
61correctly and load a subshell for you to debug the error:
62  (cd '/home/embray/src/sagemath/sage/local/var/tmp/sage/build/psutil-4.3.1' && '/home/embray/src/sagemath/sage/sage' --sh)
63When you are done debugging, you can type "exit" to leave the subshell.
64************************************************************************