Ticket #13329: prereq-1.1.2.diff

File prereq-1.1.2.diff, 6.1 KB (added by vbraun, 9 years ago)

Diff for Volker's version

  • configure.ac

    diff --git a/configure.ac b/configure.ac
    a b  
    202202# Check for Latex, the use of which is less important in Sage than
    203203# it used to be, as it was at one time required to build any documentation
    204204# but this is no longer so.
    205 
    206205AC_CHECK_PROG(found_latex,latex,[yes],[no],[])
    207206if test x$found_latex  != xyes
    208207then
     
    216215# requires version >= 5.8.0.  The R package *used* to require it, but
    217216# not anymore. -- Jeroen Demeyer
    218217AC_PATH_PROG([PERL],[perl])
    219 AX_PROG_PERL_VERSION([5.8.0],[],[AC_MSG_ERROR([Sorry, your version of perl is too old]) ])
     218AX_PROG_PERL_VERSION([5.8.0],[],[
     219    AC_MSG_ERROR([Exiting, since AC_PACKAGE_NAME requires perl-5.8.0 or later])
     220])
     221
     222# To build python you need dpkg-architecture on debian-based systems
     223AC_CHECK_PROG(found_dpkg, dpkg,[yes],[no],[])
     224AC_CHECK_PROG(found_dpkg_arch, dpkg-architecture,[yes],[no],[])
     225if test x$found_dpkg  == xyes && test x$found_dpkg_arch == xno
     226then
     227    AC_MSG_WARN([You do not have 'dpkg-architecture', which is requred to build])
     228    AC_MSG_WARN([Python on multi-arch debian systems. This is definitely requried])
     229    AC_MSG_WARN([in recent Debian and Ubuntu versions.])
     230    AC_MSG_ERROR([Exiting, since AC_PACKAGE_NAME requires dpkg-architecture on debian])
     231fi
    220232
    221233# Next one should check for libraries
    222234# No unusual libraries are needed. Sage comes with everything it needs.
     
    224236# Next one should check for header files.
    225237# complex.h is one that might not exist on older systems.
    226238AC_CHECK_HEADER([complex.h],[],[
    227      AC_MSG_WARN([complex.h not found. You don't have all the headers to build])
    228      AC_MSG_WARN([AC_PACKAGE_NAME, but the build will continue, to aid porting efforts])
     239    AC_MSG_ERROR([Exiting, since you do not have the 'complex.h' header file.])
     240])
     241
     242# The Sage Notebook requires OpenSSL headers.
     243AC_CHECK_HEADER([openssl/ssl.h],[],[
     244    AC_MSG_NOTICE([The OpenSSL library is required to build the Sage Notebook.])
     245    AC_MSG_NOTICE([You might need to execute one of the following (or the equivalent for your])
     246    AC_MSG_NOTICE([operating system):])
     247    AC_MSG_NOTICE([  sudo apt-get install libssl-dev])
     248    AC_MSG_NOTICE([  sudo yum install openssl-devel])
     249    AC_MSG_ERROR([Exiting, since the OpenSSL headers were not found.])
    229250])
    230251
    231252# Next one should check for types.
     
    302323    [
    303324    AC_MSG_NOTICE([gcc ($GCC_VERSION) and g++ ($GXX_VERSION) are not the same version])
    304325    AC_MSG_NOTICE([which they must be. Check your setting of CC and CXX])
    305     AC_MSG_ERROR([Exiting since the C and C++ compilers have different versions])
     326    AC_MSG_ERROR([Exiting, since the C and C++ compilers have different versions])
    306327    ],[],[
    307328    AC_MSG_NOTICE([gcc ($GCC_VERSION) and g++ ($GXX_VERSION) are not the same version])
    308329    AC_MSG_NOTICE([which they must be. Check your setting of CC and CXX])
    309     AC_MSG_ERROR([Exiting since the C and C++ compilers have different versions])])
     330    AC_MSG_ERROR([Exiting, since the C and C++ compilers have different versions])])
    310331
    311332    # In the paragraph below, 'gfortran' is used to indicate the GNU Fortran
    312333    # compiler, though it might be called something else.
     
    349370        echo ""
    350371        $FC --version 2>&1
    351372        echo ""
    352         AC_MSG_ERROR([Exiting since the Fortran compiler is not the same version as the C and C++ compilers])
     373        AC_MSG_ERROR([Exiting, since the Fortran compiler is not the same version as the C and C++ compilers])
    353374    else
    354375        AC_MSG_NOTICE([Excellent, the C, C++ and Fortran compilers are all GCC $GCC_VERSION])
    355376    fi
     
    360381        AC_MSG_NOTICE([GCC $GCC_VERSION is too old and can not build AC_PACKAGE_NAME. ])
    361382        AC_MSG_NOTICE([Please use a GCC of at least $minimum_gcc_version_for_no_hassle ])
    362383        AC_MSG_NOTICE([There are no plans whatsoever to support GCC $GCC_VERSION])
    363         AC_MSG_ERROR([Exiting due to the use of a version of GCC that is too old])
     384        AC_MSG_ERROR([Exiting, due to the use of a version of GCC that is too old])
    364385    ], [],[])
    365386
    366387    # Exit if Sage is *precisely* version $buggy_gcc_version1, as that is very buggy.
     
    371392    AS_VERSION_COMPARE([$GCC_VERSION], [$buggy_gcc_version1],[],[
    372393        AC_MSG_NOTICE([GCC $buggy_gcc_version1  is very buggy and can not build AC_PACKAGE_NAME.])
    373394        AC_MSG_NOTICE([Please use a gcc of at least $minimum_gcc_version_for_no_hassle.])
    374         AC_MSG_ERROR([Exiting due to the use of a version of GCC that is too buggy])
     395        AC_MSG_ERROR([Exiting, due to the use of a version of GCC that is too buggy])
    375396     ],[])
    376397
    377398    # Issue a warning if gcc is too old to work with all packages, but
     
    399420           AC_MSG_NOTICE([empty. But if you just want Sage to work, upgrade GCC ])
    400421           AC_MSG_NOTICE([******************************************************])
    401422           AC_MSG_NOTICE([******************************************************])
    402            AC_MSG_ERROR([Exiting due to the use of a version of GCC that is too old])
     423           AC_MSG_ERROR([Exiting, due to the use of a version of GCC that is too old])
    403424        fi
    404425    ],
    405426[
     
    445466# Next check for something more obscure (sqrtl) that may not exist on all maths libraries
    446467# but which is needed to build Sage.
    447468AC_CHECK_LIB(m,sqrtl,[],[
    448      AC_MSG_WARN([library function sqrtl() not found. You don't have all the functions])
    449      AC_MSG_WARN([to build AC_PACKAGE_NAME, but the build will continue, to aid porting efforts])
     469    AC_MSG_NOTICE([You have an outdated and/or broken math library.])
     470    AC_MSG_ERROR([Exiting, since the library function 'sqrtl()' was not found.])
     471])
     472
     473# OpenSSL is a prerequisite for the notebook.
     474AC_CHECK_LIB(ssl, SSL_library_init, [], [
     475    AC_MSG_NOTICE([The OpenSSL library is required to build the Sage Notebook.])
     476    AC_MSG_NOTICE([You might need to execute one of the following (or the equivalent for your])
     477    AC_MSG_NOTICE([operating system):])
     478    AC_MSG_NOTICE([  sudo apt-get install libssl-dev])
     479    AC_MSG_NOTICE([  sudo yum install openssl-devel])
     480    AC_MSG_ERROR([Exiting, since the OpenSSL library was not found.])
    450481])
    451482
    452483# Next check for system services