Ticket #11081: 11081-use-recent-gcc.patch

File 11081-use-recent-gcc.patch, 2.7 KB (added by drkirkby, 10 years ago)

Suggest use of recent gcc. Drop mention of gcc 4.3.2 being bad.

  • doc/en/installation/source.rst

    # HG changeset patch
    # User David Kirkby <david.kirkby@onetel.net>
    # Date 1302077184 -3600
    # Node ID 4f7a96adef905a9d23de1da766ee914e8536d19b
    # Parent  cca0bd9a5b4502910457a97b7b48d7764fd55fc4
    #11081 Change message from not using gcc 4.3.2 to use a recent gcc
    
    diff -r cca0bd9a5b45 -r 4f7a96adef90 doc/en/installation/source.rst
    a b  
    4747
    4848::
    4949
    50        gcc        (Version 4.0.1 or later, but do not use version 4.3.2)
    51        g++        (Version 4.0.1 or later, but do not use version 4.3.2)
    52        gfortran   (Version 4.0.1 or later, but do not use version 4.3.2)
     50       gcc        (Version 4.0.1 or later)
     51       g++        (Version 4.0.1 or later)
     52       gfortran   (Version 4.0.1 or later)
    5353       make       (GNU make, version 3.80 or later)
    5454       m4         
    5555       perl       (Version 5.8.0 or later)
     
    5959       latex      (Highly recommended, though not strictly required)
    6060
    6161The programs ``gcc``, ``g++`` and ``gfortran`` are all part of the `GNU Compiler Collection (GCC) <http://gcc.gnu.org/>`_.
     62You are generally advised to use a recent version of GCC, though
     63some obscure bugs have stopped specific versions of GCC
     64compiling Sage on particular platforms.
     65
    6266To check if you have ``m4`` installed, for example, type
    6367
    6468::
     
    164168   does not raise an ``ImportError`` then it worked.
    165169
    166170-  Sage developers tend to use fairly recent versions of gcc, but
    167    Sage should compile with almost any gcc of at least version 4.0.1. 
    168    However, version 4.3.2 of gcc should not be used, as this mis-compiles MPIR
    169    on 64-bit builds.
     171   Sage should compile with almost any gcc of at least version 4.0.1
    170172
    171173   If you are interested in working on support for commerical compilers
    172174   from `HP <http://docs.hp.com/en/5966-9844/ch01s03.html>`_,
     
    630632  problems).
    631633
    632634 :envvar:`SAGE_USE_OLD_GCC` - the Sage build process requires
    633   gcc with a version number of at least 4.0.1 -  although gcc 4.3.2 should be avoided.
     635  gcc with a version number of at least 4.0.1.
    634636  If the most recent version of gcc on your system is the older 3.4.x series and you
    635637  want to try building anyway, then set :envvar:`SAGE_USE_OLD_GCC` to
    636   something non-empty. Expect the build to fail in this case: Sage is
    637   only guaranteed to build using gcc 4.0.1 or later, (excluding gcc 4.3.2),
    638   so if you insist on working with gcc 3.4.x, you will have to modify some source code
    639   to get things to work.
    640 
     638  something non-empty. Expect the build to fail in this case.
    641639
    642640Environment variables dealing with specific Sage packages:
    643641