Ticket #11080: trac_11080-openssl-in-installation-docs.patch

File trac_11080-openssl-in-installation-docs.patch, 1.4 KB (added by kini, 9 years ago)

apply to $SAGE_ROOT/devel/sage (on top of #12899)

  • doc/en/installation/source.rst

    # HG changeset patch
    # User Keshav Kini <keshav.kini@gmail.com>
    # Date 1336404939 -28800
    # Node ID 336c38f25a25ba3505a46fac554f0c370e61c7ac
    # Parent  544e246500315ccac0d298ed1cef74e2282d8d1f
    Mention OpenSSL in the installation docs
    
    diff --git a/doc/en/installation/source.rst b/doc/en/installation/source.rst
    a b  
    4545  versions may or may not work.  On Solaris or OpenSolaris systems,
    4646  the Sun compiler should also work.
    4747- **make**: GNU make, version 3.80 or later
     48- **OpenSSL with dev headers**
    4849- **m4**
    4950- **perl**: version 5.8.0 or later
    5051- **tar**: GNU tar version 1.17 or later, or BSD tar
     
    6061- **ffmpeg**
    6162- **ssh-keygen**: needed to run the notebook in secure mode
    6263
     64.. note:: If you cannot install OpenSSL and its development headers
     65   systemwide, another option is to install the optional OpenSSL spkg
     66   into your Sage installation. Unfortunately this is not possible to
     67   do immediately after extracting the tarball, so you will need to
     68   follow the build instructions as normal, wait for the build to
     69   *fail*, then run ``sage -i openssl`` and run ``make`` again.
     70
    6371Sage also needs a C++ compiler and a Fortran compiler.
    6472However, it contains a `GNU Compiler Collection (GCC) <http://gcc.gnu.org/>`_
    6573package, such that C, C++ and Fortran compilers will be built if needed