Ticket #11070: prereq-install-changes.diff

File prereq-install-changes.diff, 2.3 KB (added by drkirkby, 10 years ago)

Differences between the old script prereq-0.7-install and the new one prereq-0.8-install

  • prereq-0.

    old new  
    77BUILD=build
    88ROOT=`pwd`
    99LOCAL="$ROOT/../local"
    10 TARGET=prereq-0.7
     10TARGET=prereq-0.8
    1111
    1212cd $BUILD
    1313
     
    3030        echo "something non-empty."
    3131        exit 1
    3232    elif [ `uname` = "SunOS" ]; then
    33        # Only use '-p option to uname on Solaris, as the option is not portable
    34        # POSIX 2004 / IEEE Std 1003.1, 2004 Edition  defines a, m, n, r, s and v
    35        # But not 'p'. Since this is only needed on Solaris, it only be executed there
    36        # It caused a problem on HP-UX 11.11, which did not support '-p'
    37        if [ "`uname -p`" != "sparc" ]; then
    38           echo ""
    39           echo "Building or using Sage on non-Sparc Solaris is tricky and not supported"
    40           echo "at the moment. It is possible, but you should be well aware that"
    41           echo "some things do not work. Support for Solaris"
    42           echo "on non-SPARC hardware is actively being worked on."
    43           echo ""
    44           echo "More information can be found about Sage on Solaris"
    45           echo "on the Wiki at http://wiki.sagemath.org/solaris"
    46           echo ""
    47           echo "To get past this message, export the variable SAGE_PORT to"
    48           echo "something non-empty."
    49           exit 1
    50        # Check for Solaris 2.6, 7, 8 and 9 and exit unless SAGE_PORT is
    51        # set. There is probably some point in supporting back to Solaris
    52        # 8, as there are still a lot of Solaris 8 installations in place
    53        # at the time of writing (December 2009). But Solaris 2.6 or 7
    54        # are very old, and really not worth the bother supporting.
    55        elif [ "x`uname -r`" = "x5.9" ] ||  [ "x`uname -r`" = "x5.8" ] || [ "x`uname -r`" = "x5.7" ] ||  [ "`uname -r`" = "x5.6" ] ; then
     33       if [ "x`uname -r`" = "x5.9" ] ||  [ "x`uname -r`" = "x5.8" ] || [ "x`uname -r`" = "x5.7" ] ||  [ "x`uname -r`" = "x5.6" ] ; then
    5634          echo "Sage is not supported on any version of Solaris earlier than 10"
    57           echo "and then only on the SPARC architecture."
    5835          echo "Sage has been tested on the first release of Solaris 10"
    5936          echo "(03/2005) and works on that. Sage may or may not work with"
    6037          echo "your version of Solaris."