Opened 7 years ago

Closed 7 years ago

#676 closed defect (wontfix)

Solaris 10: fix python build

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-3.0.1
Component: packages: standard Keywords: Solaris 10, python
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by mabshoff)

We need to add

 --with-libs='-lrt -laio -lmd -lmp -lscf -lgen -ldoor -lgcc_s
 -luutil -ldl -lm -lsocket -lnsl -lxnet'

on Solaris 10 only. It is not needed on Solaris 9.

And Solaris 10 with the Sun Forte compiler does work without the above. Solaris 10 seems to be missing symbolic links to libuutil.so.1

Change History (5)

comment:1 Changed 7 years ago by mabshoff

  • Status changed from new to assigned

comment:2 Changed 7 years ago by mabshoff

The problem seems to be Solaris 10 on amd64 specific. See

http://www.mail-archive.com/openpkg-cvs@openpkg.org/msg13989.html

for a workaround like:

if [ ".`isainfo -k`" = .amd64 ]; then
 ADD extra configure flags
fi

Cheers,

Michael

comment:3 Changed 7 years ago by mabshoff

This problem also exists on Solaris 10/Sparc. It would be interesting to see if Python 2.5.2 fixes this problem.

Cheers,

Michael

comment:4 Changed 7 years ago by mabshoff

  • Description modified (diff)
  • Milestone changed from sage-3.0 to sage-2.11

comment:5 Changed 7 years ago by mabshoff

  • Resolution set to wontfix
  • Status changed from assigned to closed

This is a non-issue with the Sun Compiler. So close it as won't fix.

Cheers,

Micahell

Note: See TracTickets for help on using tickets.