Opened 7 months ago

Closed 6 months ago

#15755 closed enhancement (fixed)

Upgrade cython to version 0.20.1

Reported by: ohanar Owned by:
Priority: major Milestone: sage-6.2
Component: packages: standard Keywords:
Cc: robertwb, mmezzarobba, jpflori Merged in:
Authors: R. Andrew Ohana, Jeroen Demeyer Reviewers: R. Andrew Ohana
Report Upstream: N/A Work issues:
Branch: faf410f (Commits) Commit: faf410f9f73d3e77c7f4062d9ea917cc87f27d3a
Dependencies: Stopgaps:

Change History (36)

comment:1 Changed 7 months ago by ohanar

  • Branch set to u/ohanar/upgrade_cython
  • Commit set to 8ab4be380e5df96263acb8a815d3ccad9438a382

Still needs some work. There seems to be some new overflow issues popping up with the libgap and polybori interfaces (at least that appears to be the issue with the failing doctests in sage.groups.matrix_gps.finitely_generated and sage.rings.polynomial.pbori).


New commits:

019d4d0cython: upgrade to 0.20
8ab4be3cython-0.20: fix doctests

comment:2 Changed 7 months ago by ohanar

  • Description modified (diff)

comment:3 follow-up: Changed 7 months ago by fbissey

well we have some fun with cython-0.20 in sage-on-gentoo since yesterday. We have a whole series of tests that fail in matroids. https://github.com/cschwan/sage-on-gentoo/issues/275 I also posted about it on the cython user list earlier today.

comment:4 in reply to: ↑ 3 Changed 7 months ago by ohanar

Replying to fbissey:

well we have some fun with cython-0.20 in sage-on-gentoo since yesterday. We have a whole series of tests that fail in matroids.

Yes, I already added a patch to revert the broken optimizations.

comment:5 follow-up: Changed 7 months ago by fbissey

I didn't see that one before posting. That's quite a lot of broken doctests without.

comment:6 in reply to: ↑ 5 Changed 7 months ago by ohanar

Replying to fbissey:

I didn't see that one before posting. That's quite a lot of broken doctests without.

Yes, it is really amazing that these are the first doctests that actually test list multiplication with more than two terms (i.e. [None] * 2 * 3 fails to produce the correct result in Cython-0.20) and that there are no tests in the Cython test suite that test such basic functionality.

comment:7 Changed 7 months ago by jdemeyer

Remember to document the patch in SPKG.txt.

comment:8 Changed 7 months ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:9 Changed 7 months ago by robertwb

Did you run into issues with PPL? E.g.

https://sage.math.washington.edu:8091/hudson/job/sage-git-build/40/consoleText

sage/libs/ppl.cpp: In function 'PyObject* __pyx_pf_4sage_4libs_3ppl_11MIP_Problem_30solve(__pyx_obj_4sage_4libs_3ppl_MIP_Problem*)':
sage/libs/ppl.cpp:5514:33: error: 'PPL_MIP_Problem_Status' in namespace 'Parma_Polyhedra_Library' does not name a type
sage/libs/ppl.cpp:5514:67: error: invalid type in declaration before ';' token
sage/libs/ppl.cpp: In function 'PyObject* __pyx_pf_4sage_4libs_3ppl_9Generator_16type(__pyx_obj_4sage_4libs_3ppl_Generator*)':
sage/libs/ppl.cpp:19487:3: error: 'PPL_GeneratorType' is not a member of 'Parma_Polyhedra_Library::Generator'
sage/libs/ppl.cpp:19487:57: error: expected ';' before '__pyx_v_t'
sage/libs/ppl.cpp:19502:3: error: '__pyx_v_t' was not declared in this scope
sage/libs/ppl.cpp: In function 'PyObject* __pyx_pf_4sage_4libs_3ppl_9Generator_40__reduce__(__pyx_obj_4sage_4libs_3ppl_Generator*)':
sage/libs/ppl.cpp:20508:3: error: 'PPL_GeneratorType' is not a member of 'Parma_Polyhedra_Library::Generator'
sage/libs/ppl.cpp:20508:57: error: expected ';' before '__pyx_v_t'
sage/libs/ppl.cpp:20527:3: error: '__pyx_v_t' was not declared in this scope
sage/libs/ppl.cpp: In function 'PyObject* __pyx_pf_4sage_4libs_3ppl_10Constraint_8type(__pyx_obj_4sage_4libs_3ppl_Constraint*)':
sage/libs/ppl.cpp:23983:3: error: 'PPL_ConstraintType' is not a member of 'Parma_Polyhedra_Library::Constraint'
sage/libs/ppl.cpp:23983:59: error: expected ';' before '__pyx_v_t'
sage/libs/ppl.cpp:23995:3: error: '__pyx_v_t' was not declared in this scope

comment:10 Changed 7 months ago by fbissey

I didn't when I built sage against pristine cython-0.20 here. In fact it all built, it just failed so many doctests on matroids it wasn't funny.

comment:11 Changed 7 months ago by fbissey

Would you actually be getting ppl headers from the distro rather than sage's one?

comment:12 Changed 7 months ago by jdemeyer

  • Branch changed from u/ohanar/upgrade_cython to u/jdemeyer/ticket/15755
  • Created changed from 01/28/14 14:35:29 to 01/28/14 14:35:29
  • Modified changed from 01/31/14 13:10:21 to 01/31/14 13:10:21

comment:13 Changed 7 months ago by jdemeyer

  • Authors set to R. Andrew Ohana
  • Commit changed from 8ab4be380e5df96263acb8a815d3ccad9438a382 to 38687c94b71a467513f0f79000e9973142545d66
  • Description modified (diff)
  • Summary changed from upgrade cython to version 0.20 to Upgrade cython to version 0.20.1

PPL problem confirmed.


New commits:

38687c9Cython: upgrade to 0.20.1

comment:14 Changed 7 months ago by git

  • Commit changed from 38687c94b71a467513f0f79000e9973142545d66 to cf1bb527e67f43b87a5661b969e6d1dcf4f295da

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

cf1bb52Cython: upgrade to 0.20.1

comment:15 Changed 7 months ago by git

  • Commit changed from cf1bb527e67f43b87a5661b969e6d1dcf4f295da to 0bbdc9ce50c8c5d3e50820639048e5fe6bc78470

Branch pushed to git repo; I updated commit sha1. New commits:

0bbdc9cFix PPL declarations

comment:16 Changed 7 months ago by git

  • Commit changed from 0bbdc9ce50c8c5d3e50820639048e5fe6bc78470 to 2b6f3da7781a9d41b4a0022f67cdfaf8d1a1a315

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

2b6f3daFix PPL and libGAP declarations

comment:17 Changed 7 months ago by git

  • Commit changed from 2b6f3da7781a9d41b4a0022f67cdfaf8d1a1a315 to b17f7c80784b19b7fe7f58ea01dc9c911d545825

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

b17f7c8Fix various declarations

comment:18 Changed 7 months ago by jdemeyer

  • Authors changed from R. Andrew Ohana to R. Andrew Ohana, Jeroen Demeyer

This last version passes doctests, but we should wait until Cython 0.20.1 is officially released.

comment:19 Changed 7 months ago by jdemeyer

  • Description modified (diff)

comment:20 Changed 7 months ago by git

  • Commit changed from b17f7c80784b19b7fe7f58ea01dc9c911d545825 to 115c8fcc196567a2f18c8dd3508cbee0ec11f809

Branch pushed to git repo; I updated commit sha1. New commits:

115c8fcFix version and checksum for Cython 0.20.1

comment:21 Changed 7 months ago by jdemeyer

  • Status changed from new to needs_review

comment:22 Changed 7 months ago by ohanar

  • Reviewers set to R. Andrew Ohana
  • Status changed from needs_review to positive_review

comment:23 Changed 6 months ago by vbraun

  • Branch changed from u/jdemeyer/ticket/15755 to 115c8fcc196567a2f18c8dd3508cbee0ec11f809
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:24 follow-up: Changed 6 months ago by vbraun

  • Commit 115c8fcc196567a2f18c8dd3508cbee0ec11f809 deleted
  • Resolution fixed deleted
  • Status changed from closed to new

Full rebuild doesn't work:

Successfully installed eclib-20140128
Deleting temporary build directory
/home/release/Sage/local/var/tmp/sage/build/eclib-20140128
Finished installing eclib-20140128.spkg
if [ -z "$SAGE_INSTALL_FETCH_ONLY" ]; then \
	cd /home/release/Sage/src && source bin/sage-env && \
	/home/release/Sage/build/pipestatus 'time python setup.py install 2>&1' 'tee -a /home/release/Sage/logs/pkgs/sage-6.2.beta2.log' && \
	touch /home/release/Sage/local/var/lib/sage/installed/sage; \
fi
Updating Cython code....
Traceback (most recent call last):
  File "setup.py", line 501, in <module>
    from Cython.Build import cythonize
ImportError: No module named Cython.Build

comment:25 Changed 6 months ago by jdemeyer

  • Branch changed from 115c8fcc196567a2f18c8dd3508cbee0ec11f809 to u/jdemeyer/ticket/15755
  • Commit set to 115c8fcc196567a2f18c8dd3508cbee0ec11f809

New commits:

cf1bb52Cython: upgrade to 0.20.1
b17f7c8Fix various declarations
115c8fcFix version and checksum for Cython 0.20.1

comment:26 in reply to: ↑ 24 Changed 6 months ago by jdemeyer

Replying to vbraun:

Full rebuild doesn't work:

What does the "full rebuild" script do? Works for me after make distclean.

comment:27 Changed 6 months ago by jdemeyer

Do you have a link to the complete install.log from that build?

comment:28 Changed 6 months ago by vbraun

Thats what I meant... maybe the failure was from another ticket. Will try again...

comment:29 Changed 6 months ago by vbraun

  • Branch changed from u/jdemeyer/ticket/15755 to 115c8fcc196567a2f18c8dd3508cbee0ec11f809
  • Resolution set to fixed
  • Status changed from new to closed

comment:31 Changed 6 months ago by jdemeyer

  • Branch changed from 115c8fcc196567a2f18c8dd3508cbee0ec11f809 to u/jdemeyer/ticket/15755
  • Commit set to 115c8fcc196567a2f18c8dd3508cbee0ec11f809

New commits:

cf1bb52Cython: upgrade to 0.20.1
b17f7c8Fix various declarations
115c8fcFix version and checksum for Cython 0.20.1

comment:32 Changed 6 months ago by jdemeyer

  • Commit changed from 115c8fcc196567a2f18c8dd3508cbee0ec11f809 to faf410f9f73d3e77c7f4062d9ea917cc87f27d3a
  • Resolution fixed deleted
  • Status changed from closed to new

New commits:

413ab85Make sure PolyBoRi hashes return Py_ssize_t
faf410fMerge branch 'u/jdemeyer/ticket/15755' of git://trac.sagemath.org/sage into ticket/15755

comment:33 Changed 6 months ago by jdemeyer

  • Status changed from new to needs_review

comment:34 Changed 6 months ago by mmezzarobba

  • Cc mmezzarobba added

comment:35 Changed 6 months ago by jpflori

  • Cc jpflori added

comment:36 Changed 6 months ago by vbraun

  • Branch changed from u/jdemeyer/ticket/15755 to faf410f9f73d3e77c7f4062d9ea917cc87f27d3a
  • Resolution set to fixed
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.