Opened 6 years ago

Closed 6 years ago

#1565 closed defect (fixed)

[Invalid?] RealDoubleField documentation missing

Reported by: phatsphere Owned by: tba
Priority: trivial Milestone: sage-3.0.3
Component: documentation Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Somewhere I read that missing documentation should be considered as a bug: sage version 2.9

RealDoubleField?
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/server4/sage_notebook/worksheets/phatsphere/0/code/11.py", line 4, in <module>
    print _support_.docstring("RealDoubleField", globals())
  File "/usr/local/sage-2.6/local/lib/python2.5/site-packages/sage/server/support.py", line 142, in docstring
    s += 'Definition:  %s\n'%sageinspect.sage_getdef(obj, obj_name)
  File "/usr/local/sage-2.6/local/lib/python2.5/site-packages/sage/misc/sageinspect.py", line 276, in sage_getdef
    spec = sage_getargspec(obj)
  File "/usr/local/sage-2.6/local/lib/python2.5/site-packages/sage/misc/sageinspect.py", line 249, in sage_getargspec
    return _sage_getargspec_cython(source)
  File "/usr/local/sage-2.6/local/lib/python2.5/site-packages/sage/misc/sageinspect.py", line 201, in _sage_getargspec_cython
    raise ValueError, "Could not parse cython argspec"
ValueError: Could not parse cython argspec

Change History (7)

comment:1 follow-up: Changed 6 years ago by mabshoff

  • Milestone set to sage-2.9.1
  • Summary changed from RealDoubleField documentation missing to [is invalid?] RealDoubleField documentation missing

I cannot reproduce this with either Sage 2.9.1.alpha1 compiled from source as well as 2.9 on sage.math:

mabshoff@sage:/tmp/Work-mabshoff/sage-2.9.1.alpha1$ ./sage
----------------------------------------------------------------------
| SAGE Version 2.9.1.alpha1, Release Date: 2007-12-18                |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------

sage: RealDoubleField?
Type:           builtin_function_or_method
Base Class:     <type 'builtin_function_or_method'>
String Form:    <built-in function RealDoubleField>
Namespace:      Interactive

sage: RealDoubleField??
Type:           builtin_function_or_method
Base Class:     <type 'builtin_function_or_method'>
String Form:    <built-in function RealDoubleField>
Namespace:      Interactive
Source:
def RealDoubleField():
    global _RDF
    return _RDF
sage:
Exiting SAGE (CPU time 0m0.02s, Wall time 0m38.13s).
mabshoff@sage:/tmp/Work-mabshoff/sage-2.9.1.alpha1$ sage
----------------------------------------------------------------------
| SAGE Version 2.9, Release Date: 2007-12-16                         |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------

sage: RealDoubleField?
Type:           builtin_function_or_method
Base Class:     <type 'builtin_function_or_method'>
String Form:    <built-in function RealDoubleField>
Namespace:      Interactive

sage: RealDoubleField??
Type:           builtin_function_or_method
Base Class:     <type 'builtin_function_or_method'>
String Form:    <built-in function RealDoubleField>
Namespace:      Interactive
Source:
def RealDoubleField():
    global _RDF
    return _RDF
sage:

Cheers,

Michael

comment:2 in reply to: ↑ 1 Changed 6 years ago by malb

  • Summary changed from [is invalid?] RealDoubleField documentation missing to RealDoubleField documentation missing

Replying to mabshoff:

I cannot reproduce this with either Sage 2.9.1.alpha1 compiled from source as well as 2.9 on sage.math:

sage: RealDoubleField?
Type:           builtin_function_or_method
Base Class:     <type 'builtin_function_or_method'>
String Form:    <built-in function RealDoubleField>
Namespace:      Interactive

Actually, you just reproduced it: There is no documentation.

comment:3 Changed 6 years ago by mabshoff

The patch for #1459 might also fix this issue.

Cheers,

Michael

comment:4 Changed 6 years ago by mabshoff

  • Summary changed from RealDoubleField documentation missing to [fixed in 2.9.1?] RealDoubleField documentation missing

comment:5 Changed 6 years ago by mabshoff

  • Summary changed from [fixed in 2.9.1?] RealDoubleField documentation missing to RealDoubleField documentation missing

This wasn't fixed in 2.9.1.

Cheers,

Michael

comment:6 Changed 6 years ago by gfurnish

  • Summary changed from RealDoubleField documentation missing to [Invalid?] RealDoubleField documentation missing

This is fixed as of 3.0.3.alpha2. Please close

comment:7 Changed 6 years ago by mabshoff

  • Milestone changed from sage-3.0.4 to sage-3.0.3
  • Resolution set to fixed
  • Status changed from new to closed

Closed since it is fixed :)

Cheers,

Michael

Note: See TracTickets for help on using tickets.