Opened 6 years ago

Closed 6 years ago

#1472 closed defect (fixed)

[with optional spkg, with positive review] gnuplotpy optional package doesn' t work with numpy

Reported by: jkantor Owned by: was
Priority: major Milestone: sage-2.9
Component: algebraic geometry Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The optional gnuplotpy package doesn't work with numpy (requires Numeric). Luckily this is fixed by doing a global search an replace of Numeric with numpy. Having done that

http://sage.math.washington.edu/home/jkantor/spkgs/gnuplotpy-1.7.p3.spkg

now works.

Change History (4)

comment:1 Changed 6 years ago by mabshoff

  • Milestone set to sage-2.9

comment:2 Changed 6 years ago by cwitty

For the sake of the reviewer, could you give an example of a command sequence that fails with the current gnuplotpy package and works with the new one?

comment:3 Changed 6 years ago by cwitty

  • Summary changed from [with optional spkg] gnuplotpy optional package doesn' t work with numpy to [with optional spkg, with positive review] gnuplotpy optional package doesn' t work with numpy

Looks good to me. Tested using sample code from http://www.math.washington.edu/~jkantor/Numerical_Sage/node13.html .

comment:4 Changed 6 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

The optional spkg has been added to sagemath.org.

Note: See TracTickets for help on using tickets.