#14333 closed defect (fixed)

singular-3-1-6 is out

Reported by: Snark Owned by: tbd
Priority: major Milestone: sage-6.2
Component: packages: standard Keywords: spkg, sd53
Cc: jpflori Merged in:
Authors: Burcin Erocal Reviewers: Jean-Pierre Flori
Report Upstream: N/A Work issues:
Branch: u/jpflori/ticket/14333 (Commits) Commit: dd469911d19ed7080fecdb90f8773c487c744a9b
Dependencies: #13770 Stopgaps:

Description (last modified by jpflori)

http://www.singular.uni-kl.de/index.php/news/release-of-singular-3-1-6.html


Sage should probably upgrade to this version; it won't be painless though, since my experiments show that what in the changelog is lightly documented as "interface to iiMake_proc changed" (in the "Internal changes" section) -- impacts sage.
The API for iiMake_proc changed from

sleftv * iiMake_proc(idhdl pn, package pack, sleftv* sl);

to

BOOLEAN iiMake_proc(idhdl pn, package pack, sleftv* sl);

Probably also take care of #12442.

Use git branch.

Upstream tarball at: http://sage.math.washington.edu/home/jpflori/upstream/singular-3.1.6.tar.bz2

Attachments (1)

trac_14333-singular_function_interface.patch (2.1 KB) - added by burcin 15 months ago.

Download all attachments as: .zip

Change History (34)

comment:1 Changed 21 months ago by leif

  • Description modified (diff)
  • Keywords spkg added

comment:2 Changed 21 months ago by leif

The patch from #14295 would have to get updated as well (as there's now one more instance of calling floor() with an int; they also added some superfluous casts, so the patch probably wouldn't apply anyway).

comment:3 follow-up: Changed 21 months ago by Snark

Wasn't that patch already updated before you submitted it on upstream's trac?

comment:4 in reply to: ↑ 3 Changed 21 months ago by leif

Replying to Snark:

Wasn't that patch already updated before you submitted it on upstream's trac?

Pardon?

(I haven't submitted a patch upstream, but only a bug report. The patch from #14295 is of course against 3-1-5, our current version, not 3-1-6.)

comment:5 Changed 21 months ago by Snark

Oh, sorry, indeed.

comment:6 Changed 21 months ago by jpflori

  • Cc jpflori added

comment:7 follow-up: Changed 19 months ago by burcin

  • Priority changed from minor to major
  • Type changed from enhancement to defect

I'm modifying the ticket priority since it fixes some problems with multivariate polynomial factorization (#14658).

comment:8 in reply to: ↑ 7 Changed 19 months ago by leif

Replying to burcin:

I'm modifying the ticket priority since it fixes some problems with multivariate polynomial factorization (#14658).

Upgrading Singular is still (hopefully) an enhancement, not a defect. (Unless you change the ticket's subject...)

comment:9 Changed 19 months ago by leif

  • Description modified (diff)

comment:10 Changed 19 months ago by leif

Just to make you aware of #14737.

comment:11 Changed 18 months ago by jpflori

It would also be nice to backport the fix needed by NTL 6.0.0: see #14876 and https://groups.google.com/d/msg/libsingular-devel/aiMvEnN8qyg/cIFUsOXxK_MJ

comment:12 Changed 17 months ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:13 Changed 16 months ago by jdemeyer

  • Description modified (diff)

comment:14 Changed 16 months ago by jdemeyer

  • Dependencies set to #13770

I'm looking into this...

comment:15 Changed 16 months ago by jdemeyer

  • Description modified (diff)

comment:16 Changed 15 months ago by burcin

  • Authors set to Burcin Erocal
  • Description modified (diff)
  • Keywords sd53 added

I uploaded a patch to take care of the API change.

New (preliminary) spkg adds two commits from singular git (1 and 2) to add compatibility with NTL 6 (#14867) and some template instantiation errors from gcc 4.7. I didn't check if the NTL stuff works.

comment:17 Changed 15 months ago by jpflori

  • Milestone changed from sage-5.12 to sage-5.13

It seems some doc in the patches section needs updating, e.g. the line about cygwin-makefile should be deleted.

We could also trigger FLINT support on as Sage now ships FLINT 2.3.

comment:18 Changed 15 months ago by jmantysalo

I was not able to compile this. After putting in http://www.singular.uni-kl.de:8002/trac/ticket/499 it compiled. However, then Sage crashes at boot and said ImportError?: /home/jm58660/sage-5.12/local/lib/python2.7/site-packages/sage/rings/polynomial/multi_polynomial_libsingular.so: undefined symbol:
_Z21nc_p_Minus_mm_Mult_qqP8spolyrecS0_S0_RiiS0_P9sip_sring

comment:19 follow-up: Changed 14 months ago by jmantysalo

FYI: There is still bug in Singular 3.1.6. At least this one sometimes (say once for every five tries) fails to factorize:

(-4*c*d + 8*d^2 + 12*f^2 + 8*a)*(8*b*c - 12*c + 4*f)*(3*a*c + 3*b*c - 
3*a*d + 33*d^2 - 3*f)*(-4*a*b - 4*b*d + 140*d^2 - 4*d*f - 4*a)*(4*a*b - 
8*b*d - 12*d^2 - 12*c*f - 8)*(-21*b*c - 3*b*d - 222*d^2 - 6*d*f - 
39*f)*(16*a*d + 128*b*d - 2)*(8*b*c + 4*c^2 - 4*b*f + 12*f)*(4*a*b + 4*b*c 
- 2*a*f + 6*f^2 - 2*b)*(-48*b^2 + 8*c*d + 144*c)*(-3*b^2 + 4*c^2 - b*d + 
f^2 + 3*a)*(4*c^2 + 4*b*d - 4*d^2 + 12*a*f)

I have already reported this, and version 4.0 should contain correction.

comment:20 in reply to: ↑ 19 ; follow-up: Changed 14 months ago by burcin

Replying to jmantysalo:

I have already reported this, and version 4.0 should contain correction.

Changing our libSingular interface to be compatible with version 4.0 is a major effort. We should backport the fix or find out the corresponding patch in the Singular master branch and add it to the spkg.

Jori, I haven't seen any responses to the email you sent to singular@mathematik.uni-kl.de. Do you have the commit id for the fix by any chance?

comment:21 in reply to: ↑ 20 Changed 14 months ago by jmantysalo

Replying to burcin:

Jori, I haven't seen any responses to the email you sent to singular@mathematik.uni-kl.de. Do you have the commit id for the fix by any chance?

I have received answers from Martin Lee. Three weeks ago he wrote "I hope that we will release a new version of Singular in the next weeks". Unfortunately I don't have id nor code; I don't know if fix for this is released at all, Martin just said that this is easy to fix.

comment:22 Changed 14 months ago by Snark

Changing the libSingular interface might be a major effort, but backporting fixes from upstream is probably not a minor effort either... the best spkg is a "./configure && make && make install"!

comment:23 Changed 14 months ago by jpflori

Is there any reason not to update to 3-1-6 (and this ticket is still in the "new" status)?
Unless 3-1-7 gets really released in the next few days?
Ok there are bugs in Singular but they were already here and should be dealt with other tickets.
Stucking with the current version we have prevent other packages to be updated (at least NTL).

comment:24 follow-up: Changed 14 months ago by jpflori

Hum, http://trac.sagemath.org/ticket/14333#comment:18 might need some investigation/work...

comment:25 in reply to: ↑ 24 Changed 14 months ago by burcin

Replying to jpflori:

Hum, http://trac.sagemath.org/ticket/14333#comment:18 might need some investigation/work...

That is probably caused by running Sage without rebuilding the library. sage -b should fix it.

comment:26 follow-up: Changed 12 months ago by jpflori

It seems 3-1-7 is not out yet, so any other reason not to put that to needs_review Burcin?

comment:27 in reply to: ↑ 26 ; follow-up: Changed 12 months ago by burcin

  • Status changed from new to needs_review

Replying to jpflori:

It seems 3-1-7 is not out yet, so any other reason not to put that to needs_review Burcin?

I am switching to needs_review. Singular 4-0-0 was released on Friday. I don't know if they plan to make bug-fix releases on the 3-1 series any more.

As I wrote before, it would be a major effort to port the libsingular interface to 4-0-0. I don't have time to do that in the near future.

comment:28 in reply to: ↑ 27 Changed 12 months ago by jpflori

Replying to burcin:

Replying to jpflori:

It seems 3-1-7 is not out yet, so any other reason not to put that to needs_review Burcin?

I am switching to needs_review. Singular 4-0-0 was released on Friday. I don't know if they plan to make bug-fix releases on the 3-1 series any more.

Ok thanks for the details.
i may be dumb but once more I did not find anything on the singular website (or at least the first thing that Google pointed at) about 4-0-0.
Note that there is indeed something here:

Is there another hidden channel where annoucements are made?

As I wrote before, it would be a major effort to port the libsingular interface to 4-0-0. I don't have time to do that in the near future.

Ok, so let's go for the 3-1-x upgrade.
I'll port the latest spkg to the new layout.

comment:29 Changed 12 months ago by jpflori

  • Branch set to u/jpflori/ticket/14333
  • Commit set to dd469911d19ed7080fecdb90f8773c487c744a9b
  • Description modified (diff)
  • Reviewers set to Jean-Pierre Flori

I'm ok with Burcin changes: it's mostly patches cleanup, integration of a few backported patches and modification for the new API as documented in the ticket description.
I also removed the description of old patches which was still there.

If someone could check I did not screw up the new layout transition I guess it can go in.
(Note that the version should be 3-1-6 but the new scripts don't support it when extraction version number, so as was done for 3-1-5, I put 3.1.6 everywhere.)


New commits:

dd46991Remove description of deleted patches.
536a31fUpdate Singular function interface to API changes in Singular 3.1.6.
1753f06Update Singular to version 3-1-6.

comment:30 Changed 12 months ago by fbissey

  • Status changed from needs_review to positive_review

Looks OK to me, we should get it in.

comment:31 Changed 12 months ago by jpflori

  • Description modified (diff)

comment:32 Changed 11 months ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:33 Changed 11 months ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.