Opened 7 years ago

Closed 7 years ago

#1421 closed enhancement (fixed)

[with patch, with positive review] finer control in ECM interface

Reported by: zimmerma Owned by: was
Priority: minor Milestone: sage-2.9.1
Component: number theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I have added a new method "one_curve" (maybe a better name can be found) to run exactly one curve (either ECM or P-1 or P+1). Also added examples for find_factor() method.

Attachments (2)

7544.patch (4.5 KB) - added by zimmerma 7 years ago.
1421-pt2.patch (770 bytes) - added by craigcitro 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by zimmerma

comment:1 Changed 7 years ago by was

code looks good -- if it passes tests, put it in.

comment:2 Changed 7 years ago by craigcitro

  • Summary changed from [with patch] finer control in ECM interface to [with patch, with positive review] finer control in ECM interface

Fixed one line in the original patch -- it creates a string to return as the error message, and then accidentally returns something other than that string (which I'm assuming wasn't the intended behavior).

Changed 7 years ago by craigcitro

comment:3 Changed 7 years ago by rlm

  • Resolution set to fixed
  • Status changed from new to closed

Merged in 2.9.1.alpha1

Note: See TracTickets for help on using tickets.