Opened 2 years ago

Closed 7 months ago

#13712 closed defect (fixed)

wrong evaluation of infinite sum

Reported by: burcin Owned by: burcin
Priority: major Milestone: sage-6.3
Component: symbolics Keywords: maxima
Cc: Merged in:
Authors: Travis Scrimshaw Reviewers: Jeroen Demeyer, Karl-Dieter Crisman
Report Upstream: N/A Work issues: add doctest
Branch: 6e7166a (Commits) Commit: 6e7166a97e56ed09a205873294aff31655e9a7fc
Dependencies: #13973 Stopgaps:

Description

From this ask.sagemath.org question:

sage: n = var('n')
sage: sum(1/((2*n-1)^2*(2*n+1)^2*(2*n+3)^2), n, 0, oo)
3/256*pi^2 - 1/32

The correct answer is 3/256*pi^2.

We should report this to maxima:

(%i10) load(simplify_sum);
(%o10) /tmpbig/burcin/sage-5.4/local/share/maxima/5.26.0/share/contrib/solve_r\
ec/simplify_sum.mac
(%i11) simplify_sum(sum(1/((2*n-1)^2*(2*n+1)^2*(2*n+3)^2), n, 0, inf));

                                          2
                                       %pi
                                   2   ---- - 4
                                %pi     2
(%o11)                          ---- + --------
                                128      128

Change History (17)

comment:1 Changed 2 years ago by kcrisman

  • Report Upstream changed from N/A to Reported upstream. No feedback yet.

I can confirm this is true in Maxima 5.28.0 as well. This is now Maxima artifact 3587514.

comment:2 Changed 19 months ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Fixed in Maxima 5.30.0: #13973.

comment:3 Changed 19 months ago by jdemeyer

  • Report Upstream changed from Reported upstream. No feedback yet. to Fixed upstream, in a later stable release.
  • Status changed from needs_review to positive_review

comment:4 Changed 19 months ago by jdemeyer

  • Milestone changed from sage-5.10 to sage-5.11

comment:5 Changed 19 months ago by jdemeyer

  • Status changed from positive_review to needs_work

Should add doctest.

comment:6 Changed 17 months ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:7 Changed 11 months ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:8 Changed 8 months ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:9 Changed 7 months ago by pbruin

  • Dependencies set to #13973
  • Report Upstream changed from Fixed upstream, in a later stable release. to N/A
  • Work issues set to add doctest

After #13973:

sage: n = var('n')
sage: sum(1/((2*n-1)^2*(2*n+1)^2*(2*n+3)^2), n, 0, oo)
3/256*pi^2

comment:10 Changed 7 months ago by tscrim

  • Authors set to Travis Scrimshaw
  • Branch set to public/ticket/inf_sum_doctest-13712
  • Commit set to 6e7166a97e56ed09a205873294aff31655e9a7fc
  • Status changed from needs_work to needs_review

Done (at least in someplace where I think it's natural...)


New commits:

6e7166aAdded doctest for ticket.

comment:11 Changed 7 months ago by kcrisman

This is not a useful commit, unfortunately, because this depends on #13973 which isn't in 6.3.beta2, as far as I can tell. I just wasted a lot of time discovering this, and I don't have enough git prowess to figure out how to "merge" this into that ticket's tree.

comment:12 follow-up: Changed 7 months ago by tscrim

git merge trac u/pbruin/13973-maxima_update or whatever your remote for trac is (the other likely one is origin).

comment:13 in reply to: ↑ 12 Changed 7 months ago by kcrisman

git merge trac u/pbruin/13973-maxima_update or whatever your remote for trac is (the other likely one is origin).

Apparently my remote is indeed trac but this command doesn't work, nor do I have any idea what the branch is since that ticket seems to have a branch called "a130eed".

Okay, the following sequence worked:

$ git fetch trac refs/heads/u/pbruin/13973-maxima_update:refs/remotes/trac/u/pbruin/13973-maxima_update
$ git merge trac/u/pbruin/13973-maxima_update

This is so frustrating compared to the old system.

comment:14 Changed 7 months ago by tscrim

Ack sorry, I meant git pull trac u/pbruin/13973-maxima_update (which, in effect, combines those two) (also in case you are unaware, you can also delete the temp branch by git branch -D name/of/branch).

comment:15 Changed 7 months ago by kcrisman

  • Reviewers changed from Jeroen Demeyer to Jeroen Demeyer, Karl-Dieter Crisman
  • Status changed from needs_review to positive_review

Okay, finally I got it all working and positive review!

comment:16 Changed 7 months ago by tscrim

Thanks. Sorry about mixing my git commands up!

comment:17 Changed 7 months ago by vbraun

  • Branch changed from public/ticket/inf_sum_doctest-13712 to 6e7166a97e56ed09a205873294aff31655e9a7fc
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.