Opened 6 years ago

Closed 6 years ago

#1336 closed defect (fixed)

[with patch, with positive review] 2.8.14/Linux PPC: rings/polynomial/polynomial_element.pyx doctest failure

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-2.8.15
Component: doctest coverage Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

On Linux PPC the following doctest fails due to numerical noise:

File "polynomial_element.pyx", line 2371:
    sage: f.roots(multiplicities=False)
Expected:
    [-1.6772670339941..., 0.199954796285..., 0.200045306115..., 1.5763035161844...]
Got:
    [-1.67726703399418, 0.199954796284890, 0.200045306115409, 1.57630351618444]

The attached patch fixes that.

Cheers,

Michael

Attachments (1)

Sage-2.8.14-polynomial_element-doctest-fix-PPCLinux.patch (955 bytes) - added by mabshoff 6 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by mabshoff

  • Status changed from new to assigned

comment:2 Changed 6 years ago by cwitty

  • Summary changed from [with patch] 2.8.14/Linux PPC: rings/polynomial/polynomial_element.pyx doctest failure to [with patch, with positive review] 2.8.14/Linux PPC: rings/polynomial/polynomial_element.pyx doctest failure

Looks good to me.

comment:3 Changed 6 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in 2.8.15.alpha0.

Note: See TracTickets for help on using tickets.