Opened 2 years ago

Closed 23 months ago

#13292 closed defect (fixed)

Bad symlink SAGE_DATA/graphs/graphs.db in binary distributions

Reported by: steven Owned by: tbd
Priority: major Milestone: sage-5.4
Component: distribution Keywords: broken symlink, graphs database, binary distributions bdist
Cc: jdemeyer, schilly Merged in:
Authors: Jeroen Demeyer Reviewers: Leif Leonhardy
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I downloaded the file sage-5.1-linux-64bit-ubuntu_12.04_lts-x86_64-Linux.tar.lzma from the official website. Sage was unable to use the graphs database.

An example of failure is (taken from the documentation):

Q = GraphQuery(display_cols=['graph6','num_vertices','degree_sequence'],num_edges=['<=',5],min_degree=1)

The file SAGE_DATA/graphs/graphs.db is a broken symlink to /tmp/graphs.db.cm5Li3EYGT. Replacing it with a link to graphs.db.orig fixed the problem.

From sage root directory:

$ cd data/graphs
$ rm graphs.db
$ ln -s graphs.db.orig graphs.db
$ ls -l
total 2452
lrwxrwxrwx 1 steven steven      14 Jul 26 14:35 graphs.db -> graphs.db.orig
-rw-r--r-- 1 steven steven 1258496 May 20  2007 graphs.db.orig
-rw-r--r-- 1 steven steven 1247018 Apr  4 21:56 isgci_sage.xml

Change History (12)

comment:1 follow-up: Changed 2 years ago by leif

  • Component changed from databases to distribution
  • Keywords binary distributions bdist added
  • Owner changed from was to tbd

I can confirm that random symbolic links are at least in all current binary dists for Linux:

-rw-r--r-- buildbot/buildbot 1258496 2007-05-19 22:10 sage-5.1-linux-32bit-ubuntu_12.04_lts-i686-Linux/data/graphs/graphs.db.orig
lrwxrwxrwx buildbot/buildbot       0 2012-07-09 07:58 sage-5.1-linux-32bit-ubuntu_12.04_lts-i686-Linux/data/graphs/graphs.db -> /tmp/graphs.db.oWJyOif14b
lrwxrwxrwx buildbot/sage        0 2012-06-10 20:48 sage-5.0.1-linux-32bit-fedora_release_16_verne_-i686-Linux/data/graphs/graphs.db -> /tmp/graphs.db.3JgdyXfStN
-rw-r--r-- buildbot/sage  1258496 2007-05-19 22:10 sage-5.0.1-linux-32bit-fedora_release_16_verne_-i686-Linux/data/graphs/graphs.db.orig
lrwxrwxrwx buildbot/sage        0 2012-06-09 23:31 sage-5.0.1-linux-64bit-fedora_release_16_verne_-x86_64-Linux/data/graphs/graphs.db -> /tmp/graphs.db.PHqLo6OMpQ
-rw-r--r-- buildbot/sage  1258496 2007-05-19 22:10 sage-5.0.1-linux-64bit-fedora_release_16_verne_-x86_64-Linux/data/graphs/graphs.db.orig
lrwxrwxrwx buildbot/buildbot         0 2012-07-09 08:40 sage-5.1-linux-64bit-ubuntu_12.04_lts-x86_64-Linux/data/graphs/graphs.db -> /tmp/graphs.db.cm5Li3EYGT
-rw-r--r-- buildbot/buildbot   1258496 2007-05-19 22:10 sage-5.1-linux-64bit-ubuntu_12.04_lts-x86_64-Linux/data/graphs/graphs.db.orig

Haven't yet tracked this down.

comment:2 in reply to: ↑ 1 Changed 2 years ago by leif

Replying to leif:

I can confirm that random symbolic links are at least in all current binary dists for Linux...

On the other hand, I cannot reproduce this error (with Sage 5.2.rc0). I.e., sage -bdist works for me w.r.t. this.

comment:3 Changed 2 years ago by leif

sage-bdist looks sane as well, so that's probably a problem with the buildbot setup or other scripts not part of the Sage distribution itself.

comment:4 Changed 2 years ago by leif

  • Cc jdemeyer schilly added
  • Priority changed from major to blocker
  • Summary changed from Bad symlink SAGE_DATA/graphs/graphs.db to Bad symlink SAGE_DATA/graphs/graphs.db in binary distributions

Unfortunately this is still true for the new 5.2 binaries, at least all the Linux ones.

comment:5 Changed 2 years ago by jdemeyer

It's because of the buildbot setup.

This goes back to the Mitesh Patel days, which is sage-4.6 or something. So I don't understand why nobody ever noticed this before.

comment:6 Changed 2 years ago by leif

FWIW, some of the temporaries are kept as well:

leif@redhawk:~$ ls -l /tmp/graphs.db.*
-rw------- 1 buildbot buildbot 1258496 2012-07-27 05:51 /tmp/graphs.db.Uc0awza1Zl
-rw------- 1 buildbot buildbot 1258496 2012-07-27 02:01 /tmp/graphs.db.zX74CFVi9b

No idea why they're copied to /tmp at all, since the database is fairly small.

At least the original files are also part of the bdists...

comment:7 follow-up: Changed 2 years ago by jdemeyer

  • Priority changed from blocker to major

I agree it should be fixed, but I don't see why it should be a "blocker".

comment:8 in reply to: ↑ 7 Changed 2 years ago by leif

Replying to jdemeyer:

I agree it should be fixed, but I don't see why it should be a "blocker".

Because otherwise nobody notices this issue... ;-)

comment:9 follow-up: Changed 2 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Status changed from new to needs_review

Fixed this on the buildbot and made one new binary: http://boxen.math.washington.edu/home/buildbot/binaries/sage/5.2.rc1/sage-5.2.rc1-linux-64bit-ubuntu_8.04.4_lts-x86_64-Linux.tar.gz

If this looks good, please set this to positive_review.

comment:10 in reply to: ↑ 9 Changed 2 years ago by leif

Replying to jdemeyer:

Fixed this on the buildbot and made one new binary: http://boxen.math.washington.edu/home/buildbot/binaries/sage/5.2.rc1/sage-5.2.rc1-linux-64bit-ubuntu_8.04.4_lts-x86_64-Linux.tar.gz

If this looks good, please set this to positive_review.

Well, the new bdist tarball looks sane w.r.t. graphs.db (and I haven't found other references to temporary files), but I (so far) haven't tested the bdist itself, and I should probably review the change(s) to some script(s)...

comment:11 Changed 23 months ago by jdemeyer

  • Milestone changed from sage-5.4 to sage-5.5
  • Reviewers set to Leif Leonhardy
  • Status changed from needs_review to positive_review

The buildbot scripts aren't part of Sage, so I don't think these need to be reviewed. Anyway, the problem is fixed.

comment:12 Changed 23 months ago by jdemeyer

  • Milestone changed from sage-5.5 to sage-5.4
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.