Opened 6 years ago

Closed 6 years ago

#1283 closed defect (duplicate)

Update coercion model API

Reported by: robertwb Owned by: somebody
Priority: major Milestone: sage-2.10.2
Component: basic arithmetic Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by mabshoff)

Currently, coercions (and conversions) are defined in many different places in the SAGE codebase. We are going through each parent and consolidating/cleaning up the codebase to conform to the new coercion API, as described in the new programming guide.

This includes removing all Parent __call__ methods to use a generic __call__.

Attachments (1)

coerce-migration.hg (32.8 KB) - added by robertwb 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by mabshoff

  • Description modified (diff)
  • Milestone set to sage-2.9

Changed 6 years ago by robertwb

comment:4 Changed 6 years ago by robertwb

  • Milestone changed from sage-2.10.3 to sage-2.10.2
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #2314

Note: See TracTickets for help on using tickets.