Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11260 closed defect (duplicate)

ECL-11.1.1 fails to compile maxima on WIndows 7 / Cygwin 1.7.9

Reported by: dimpase Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords: fork, remap, ecl
Cc: Merged in:
Authors: Reviewers: Dmitrii Pasechnik
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by dimpase)

The problem is specific to Windows 7, and (most probably---untested) other newer than XP Windows releases, like Vista, etc. On these systems Cygwin has still some glitches related to fork etc... Note that it builds fine under WinXP.

Symptoms - dreadfully looking errors on address spaces of DLLs with temporary names, and dead or dying forks...

;      - Compiling source file
;        "/home/dima/sage-4.7.alpha5/spkg/build/maxima-5.23.2/src/src/clmacs.lis
p"
;;;
;;; Compiling /home/dima/sage-4.7.alpha5/spkg/build/maxima-5.23.2/src/src/clmacs
.lisp.
;;; OPTIMIZE levels: Safety=2, Space=0, Speed=3, Debug=2
;;;
;;; Compiling (DEFUN MEMQ ...).

[...]

;;; Emitting code for DO-MERGE-SYMM.
;;; Emitting code for DO-MERGE-ASYM.
;;; Note:
;;;   Constant value optimized away or not used
;;; (t)
;;; Note:
;;;   Invoking external command:
;;;   gcc -I. -I/home/dima/sage-4.7.alpha5/local/include/ -I/home/dima/sage-4.7.
alpha5/local/include -g -O2 -Dcygwin -O2 -w -c binary-ecl/clmacs.c -o binary-ecl
/clmacs.o
;;; Finished compiling /home/dima/sage-4.7.alpha5/spkg/build/maxima-5.23.2/src/s
rc/clmacs.lisp.
;;;
;;; Note:
;;;   Invoking external command:
;;;   gcc -I. -I/home/dima/sage-4.7.alpha5/local/include/ -I/home/dima/sage-4.7.
alpha5/local/include -g -O2 -Dcygwin -O2 -w -c /tmp/eclinit7mTHXx.c -o /tmp/ecli
nit7mTHXx.o
      4 [main] ecl 2684 C:\cygwin\home\dima\sage-4.7.alpha5\local\bin\ecl.exe: *
** fatal error - unable to remap \\?\C:\cygwin\tmp\eclBeSwlo.dll to same address
 as parent: 0x320000 != 0x420000
      4 [main] ecl 2684 C:\cygwin\home\dima\sage-4.7.alpha5\local\bin\ecl.exe: *
** fatal error - unable to remap \\?\C:\cygwin\tmp\eclBeSwlo.dll to same address
 as parent: 0x320000 != 0x420000
Stack trace:
Frame     Function  Args
0022A4B8  6102796B  (0022A4B8, 00000000, 00000000, 00000000)
0022A7A8  6102796B  (6117EC60, 00008000, 00000000, 61180977)
0022B7D8  61004F1B  (611A7FAC, 6124AB54, 00320000, 00420000)
End of stack trace
      3 [main] ecl 3168 fork: child 2684 - died waiting for dll loading, errno 1
1
      3 [main] ecl 3168 fork: child 2684 - died waiting for dll loading, errno 1
1
An error occurred during initialization:
Could not spawn subprocess to run "gcc"..
;;; Note:
;;;   Invoking external command:
;;;   gcc -o binary-ecl/clmacs.fas -L/home/dima/sage-4.7.alpha5/local/lib/ /tmp/
eclinit7mTHXx.o binary-ecl/clmacs.o -shared -L/home/dima/sage-4.7.alpha5/local/l
ib -Wl,--enable-auto-image-base -L/home/dima/sage-4.7.alpha5/local/lib -Wl,--ena
ble-auto-image-base -lecl -lgmp -lgc -lm make[1]: *** [binary-ecl/maxima] Error
1
make[1]: Leaving directory `/home/dima/sage-4.7.alpha5/spkg/build/maxima-5.23.2/
src/src'
make: *** [install-recursive] Error 1
***********************************************************
Failed to install Maxima.
***********************************************************

Change History (11)

comment:1 Changed 3 years ago by drkirkby

I've posted this to the ecl list, but it would probably help if you attached build logs of ECL and Maxima.

comment:2 Changed 3 years ago by drkirkby

  • Report Upstream changed from N/A to Reported upstream. Developers acknowledge bug.

The ECL developer Juanjo has written on the ECL and sage-devel lists:

I know about these bug reports -- similar ones appeared on a different context --. Unfortunately I am at a peak of work load and will solve them slower than usual. Thanks for reminding.

comment:3 Changed 3 years ago by dimpase

  • Description modified (diff)

comment:4 Changed 3 years ago by kcrisman

Data point: Maxima compiled successfully on my Windows 7 machine just now. ./sage -maxima worked and I integrated 2x. I did not do anything special to get this to happen.

comment:5 Changed 3 years ago by kcrisman

I should say that I did see several "fork" and "waiting for resource" errors, but those apparently weren't fatal. So it may be that Maxima and anything else that needs fork will work randomly, depending on what else the system is up to.

comment:6 Changed 3 years ago by kcrisman

This time Maxima failed to build with the usual fork errors. I'm trying make again.


Juanjo reports that he has changed the way ECL handles forking on Cygwin so that this will not be a problem - the Maxima folks want it to work too - though it removes some capabilities on Cygwin. Apparently, that won't be a problem for Sage, however.

comment:7 Changed 3 years ago by kcrisman

  • Report Upstream changed from Reported upstream. Developers acknowledge bug. to Fixed upstream, but not in a stable release.

dimpase reports on this sage-devel thread (at the very end) that Maxima now compiles on Windows 7 with the new ECL spkg for Lion at #11884.

My guess is that if Dima positively reviews as sage-invalid, that would be sufficient. This would not close #11502 since that is an XP problem, though likely we will simply just forget about XP soon.

comment:8 Changed 3 years ago by kcrisman

  • Milestone changed from sage-4.8 to sage-duplicate/invalid/wontfix
  • Reviewers set to Dima Pasechnik
  • Status changed from new to needs_review

Dima, I've set this one as well to sage-invalid. If you agree with this, just set to positive review.

comment:9 Changed 3 years ago by dimpase

  • Status changed from needs_review to positive_review

comment:10 Changed 3 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:11 Changed 3 years ago by jdemeyer

  • Reviewers changed from Dima Pasechnik to Dmitrii Pasechnik
Note: See TracTickets for help on using tickets.